4
$\begingroup$
  1. I downloaded the KhronosGroup addon from https://github.com/KhronosGroup/glTF-Blender-Exporter
  2. I read install instructions, but those were for Windows.
  3. I tried copying the addon under ~/.blender/2.79/scripts/addons/io_scene_gltf2 but Blender shows nothing
  4. I tried to install via "install from file" and selecting the exporter .py file directly but nothing happens.
  5. I checked version, I am sitting in 2.79 Blender and the script is for 2.78. I tried to fool Blender by changing the scripts version in to 2.79 but no luck.

Any way to get this thing to work on Linux and on this Blender version?

$\endgroup$
  • $\begingroup$ Copying io_scene_gltf2 into scripts/addons as per the readme worked fine for me in 2.79b under Archlinux. Have you tried refreshing Blender? $\endgroup$ – gandalf3 Mar 31 '18 at 19:00
  • $\begingroup$ To which exact path did you copy the file into if I may ask? Also, what do you mean by refreshing? Restarted many times if that's it. $\endgroup$ – Mikko-Pentti Einari Eronen Mar 31 '18 at 19:02
  • 3
    $\begingroup$ I copied glTF-Blender-Exporter/scripts/addons/io_scene_gltf2 to ~/.config/blender/2.79/scripts/addons/io_scene_gltf2. Restarting Blender would certainly do it; there's also a refresh button in the bottom right corner of the addon list $\endgroup$ – gandalf3 Mar 31 '18 at 19:04
2
$\begingroup$

Thank you gandalf3. My mistake was the path. I tried ~/.blender folder when in fact I had to copy the addon under ~/.config/blender/..

Works now, thank you again!

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.