0
$\begingroup$

Having an issue with an object upon export. Everything looks fine in blender:

enter image description here

But when I export it to another format, something is happening that displays textures on the incorrect side of faces (at least that's what I can tell is happening)

enter image description here

I then proceeded to double check that all of the normals are pointed in the correct locations (and that this object was manifold) and everything looks to be fine:

enter image description here

Not sure where to go from here? I was going to re-model the object, but if someone knows of something else to try, I'd rather know what is causing this in case I run into it again in the future.

EDIT

It might be helpful to mention that this is one object in a scene of multiple and it is the only one exhibiting this behavior, which is why I'm led to believe it's something to do with the object itself (all other objects render as expected when exported from the scene with same settings).

The format being exported is .obj. The .obj is being imported into a program which utilizes the irrlicht engine.

EDIT AGAIN

Remodeling the object in blender took care of the issue. Guessing it had to be something with either the model or the uv map.

$\endgroup$
  • $\begingroup$ That can be either an export problem or an import problem is the other tool you export to. What is this tool? What is the export format? Which options have you set in Blender in the export parameters (generally on the bottom left of the export window)? $\endgroup$ – lemon Mar 31 '18 at 6:09
  • $\begingroup$ @lemon Question updated with further details. $\endgroup$ – nullReference Mar 31 '18 at 14:37
  • $\begingroup$ I don't know for Irrlicht, but I had to code an OBJ importer for Unity. In this case inverting vertices on X axis was needed (from standard export settings (-Z forward and Y up). I think it is the same here. You should try to play with the export parameters in Blender or similar parameters when importing in Irrlicht. $\endgroup$ – lemon Mar 31 '18 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.