1
$\begingroup$

I am making a sprinkles on donut using particles but blender (2.79a) changes the size of the particles even though, random size is on 0 value.

enter image description here

Edit:

I tried changing type to emitter which made the them all same size but, also resulted in sprinkles placed randomly around glazing

enter image description here

I also have a box under my glazing which is only place I can use to move the glazing and I wonder if this is a cause of my problem.

enter image description here

$\endgroup$
  • $\begingroup$ In the type choose Emitter. In physics size to 1 and random to 0 $\endgroup$ – atek Mar 30 '18 at 17:12
  • $\begingroup$ @atek Hey, thanks for your reply! I just did and the emitter just throws them away from the donut. Also, I have 2.79a and there is no size bar in physics. $\endgroup$ – Michal Mar 31 '18 at 18:47
  • $\begingroup$ Emitter and Hair are quite a bit different modes of emitting particles and changing one to another just because of adjusting randomness in size isn't correct. What settings did you use to vary rotation of particles? If you used Velocity > Random then it affects scale as well $\endgroup$ – Mr Zak Mar 31 '18 at 22:23
  • $\begingroup$ @Mr Zak I used rotation settings to change rotation and haven't changed anything in velocity but they all still vary in size. These are my particles settings. i.stack.imgur.com/Rx8Hn.png And when I unclick the advanced box I can change size and random size in render but it was on 0 from the beggining i.stack.imgur.com/l2mue.png $\endgroup$ – Michal Apr 1 '18 at 9:42
  • $\begingroup$ Option in the Velocity rollout > Other group > Random is set to 1 on your screenshot. It allows to randomize rotation of the particles but size as well (as it affects starting velocity of the hair) even if random size in Render rollout is set to 0. By default it's set to 0. If you really want to make all particles of the same size (icicles on donut won't be) you can set that to 0, open Rotation rollout, set it to Normal or Normal-Tangent and increase Random of the Phase to 2. Then only rotation will be randomized $\endgroup$ – Mr Zak Apr 1 '18 at 12:55
1
$\begingroup$

Thanks for you answers guys!

As Mr Zak pointed Random in my Velocity settings was set to 1 instead of 0 which I probably changed to see what it is doing and simply turn it to 1 thinking that is the default value. I changed it back to 0 and all the particles are the same size.

Again, thanks for your help!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.