4
$\begingroup$

I got a weird problem. Patches of hair on a rug for a bathroom scene are disappering in my render, but only if I entered particle edit Mode and combed the hair before.

So, I start out setting up my hair system, when I hit render without entering the particle edit Mode I get a nice render just like its supposed to look. All the hair is also howing in the viewport before and after this render.

I enter particle edit mode, just make a single tiny stroke with the comb, exit into object mode again. All the hair is still showing in the viewport at this point, I can also so see my "comb-job" in the viewport.

When I now hit render though, whole patches of hair just disappear from the render. Its also not like that the areas I combed before disappear and the ones I left untouched are still showing, there seems to be no connection between where I comb and what disappears.

After this render finishes the hair (same hair as in render result) is also missing in the viewport.

My emitter is just a plane, rotation and scale all applied, with a subsurf modifier. Use modifier stack is enabled. I´m aware that particles won´t render when you´re still in particle edit mode, I always changed back to object mode before rendering. Does anyone have an idea whats causing this and how to fix it?

Thanks in advance enter image description here enter image description here

$\endgroup$
  • $\begingroup$ Can you post an image of your particle settings? $\endgroup$ – Scott Milner Mar 29 '18 at 0:20
  • $\begingroup$ Sure, added it to my first post. $\endgroup$ – kRz Mar 29 '18 at 13:42
  • $\begingroup$ Nobody got any ideas? $\endgroup$ – kRz Apr 2 '18 at 17:30
0
$\begingroup$

You have $300000$ individual hairs right now. I suspect that your issue stems from that very high number of edited particles. To fix this, use Particle Children. Set your Emission number to something lower, like $3000$ or $1000$. Then, enable Interpolated children:

enter image description here

You can set the Render parameter so that the total number of children is equal to $300000$, (i.e. $3000\cdot 100=300000$).

You can now use Particle Edit to comb your particles. They should take up less memory now, and hopefully render correctly.

$\endgroup$
  • $\begingroup$ I´ll try what you suggestet tomorrow. But i dont think this is the culprit, besides the rug I have another 5 towels in my scene, each with with a million hairs. All 4 render without any problems. I even deactivated them for the test renders in the screenshots your seeing to to make sure "too many particles" couldnt be the case. $\endgroup$ – kRz Apr 2 '18 at 23:59
  • $\begingroup$ did you ever fix this. This is happening to me too now. Renders fine until I use particle edit mode. Just a few hundred leaves in my case. $\endgroup$ – user3597862 Mar 12 at 10:37
  • $\begingroup$ This behavior is most likely a bug, and isn't intended. What I've answered is a suggested best practice to get around it, but it would perhaps be a good idea to report a bug. $\endgroup$ – Scott Milner Mar 12 at 16:56
  • $\begingroup$ Thanks scott, seems really odd because I have other objects in the scene that are using particle edit and they appear to work perfectly, so it can't be a render setting thats wrong etc. Stumped. Thanks anyway. $\endgroup$ – user3597862 Mar 12 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.