0
$\begingroup$

I have made a complex ribbon-like structure (DNA strand), rigged it with bendy bones and made it follow an Archimedic spiral. In one strand, this worked perfectly (1st image), in the other some vertices don't follow their bones (2nd image). Deform is turned on for these bones, the weight paint is right - what else could be the problem?

It is maybe notable that I made and rigged the ribbon by duplicating a ribbon half it's length. Indeed, the same three elements of the ribbon are affected (the last three of the original ribbon).

ribbon nicely following the spiral

Please note that in the above image I already adjusted the rotation of the elements to all point inwards.

some vertices do not follow the spiral

EDIT: I assigned the vertex groups to the bones by hand so this is likely not the problem, I also tried user9288082's answer, to no avail. So here is the .blend file: https://www.dropbox.com/s/y5nmq0palokfs0u/vertices_dont_follow.blend?dl=0

$\endgroup$
2
$\begingroup$

I found the problem, thanks to this answer. It turns out the vertices in question were also controlled by a bone at the very end of the chain.

What I did:

  1. select the mesh, go into edit mode;
  2. select one vertex inside the problematic part of the mesh and bring up the properties bar by pressing N;
  3. under Vertex Weights, check the names of the bones controlling this vertex, there should be one/several too many;
  4. in Pose Mode, select the bone that should not be on that list;
  5. in Weight Paint mode, choose "Subtract" as mode for the Weight Brush and paint over the red areas that should not be controlled by this bone.
$\endgroup$
0
$\begingroup$

Despite your verification, you may still have vertices with a bad weight. To be absolutely sure about it: 1-select all your points in edit mode 2-Switch to edit mode : select armature + shift mesh switch weight paint 3- On the weight paint menu click on the option: "face selection masking for painting"(see image joint) 4-On the weight paint menu also click on the "limit selection to visible" option 5-Then paint the vertices remaining on the spot with a weight of 0. The vertices should follow the bone concerned because your paint also in back vertices. If this solution does not work. Send your blend file. enter image description here

$\endgroup$
  • $\begingroup$ Thanks for the answer. Unfortunately, I am having some trouble following your instructions. What do you mean by "select all your points"? Do you mean vertices? $\endgroup$ – Anne Morbach Mar 26 '18 at 15:29
  • $\begingroup$ I tried it, it didn't change anything. I uploaded the .blend file, the link is at the end of my original question. $\endgroup$ – Anne Morbach Mar 26 '18 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.