2
$\begingroup$

I have figured out what was wrong with the smoke, I could render it but I could not see it but it was there just the same, thank you. Now when I try and render two different smoke colors they both come out the same. I have gone into the compositor and created two different settings but I cannot apply them, also when creating two separate domain boxes and two emitters they only take one setting. I have tried to put them on separate layers but this does not work either, I do not want to go into the video sequence editor as this is long. Is there a solution for this?

$\endgroup$
  • 1
    $\begingroup$ Well, not very clear... Did you create 2 distinct materials for your 2 distinct smokes ? I recommend you to be more specific in your question... Send some screenshots, etc. $\endgroup$ – Polosson Jun 14 '13 at 12:10
  • $\begingroup$ Yes I did create 2 distinct materials and 2 different smokes, I thought I'd make that clear when I wrote "and created 2 different settings in the composition node editor". Even with 2 different settings and 2 different colours, both smoke generators take on one colour. I cannot get Blender to treat the 2 differently ie asign the composition node editors to the 2 seperate smoke generators. Screen shots to follow........thanks $\endgroup$ – Lindsey Jun 14 '13 at 13:34
  • 1
    $\begingroup$ I still suspect that you are using shared datablocks. Make sure that materials are all single-user. All textures are single-user, and all smoke systems are single-user. $\endgroup$ – Mike Pan Jun 15 '13 at 3:13
1
$\begingroup$

It sounds like your materials or your textures or your caches are linked. You can check this by changing one setting for Smoke A and see if it applies for Smoke B. If so, then your issue is linking.

To get rid of the link, click the button with the number on it next to the material and texture. That should fix it.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.