4
$\begingroup$

I'm trying to make some beams coming out of the headlights to give the render a bit of atmosphere but I only want it to come out the headlights so I created an area in which to do so but it fades from the desired blue light to a white haze rather than to nothing. I've put a couple of vague reference images. I added a couple of area lamps just in front of the actual headlights as I still wanted to see the blue and the details in the headlights (as there is also another light source but more dim inside the headlights). Do you think perhaps it would be better to make particles for the light to bounce off?

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here Thanks in advance

$\endgroup$
5
$\begingroup$

The issue is that your volume scattering domain is interacting with all of the other lights on the scene. To make it the less visible you could use a gradient texture node and a color ramp (as detailed in this answer), or you can do a quick trick at the expense of realism by suppresing shadow rays for on the volume scatter object and disabling volume scattering rays in the rest of the lamps.

Select the object you are using as container for volume scattering and disable Shadow in the Ray visibility section of Cycles settings.

enter image description here

(also get rid of the volume absorption and add shader nodes you are using in the materials)

Then disable visibility for volume scatter for all of the other lights on the scene (so that they do not interact with the volumetric rays).

enter image description here

Another issue with your file is that you have a very low number of bounces for the headlights of your vehicle (Area and Area.001). In the settings for bounces bring up the value to 1024.

Lastly, know that you are going to need a lot of samples to render the image (don't rely on the denoiser, it will smudge your image)

I rendered a preview using branched path tracing using 300 AA samples and 900 for volume. But you might need more samples to get a clean image at the 8.7k render you want to do....

enter image description here

An alternative to this is not to use a mesh for volume scattering, and use volume scattering in the world and use cone lamps in the headlights instead. (all other lights still need to be disabled for Volume Scatter rays). This will give you a more natural effect, as in real life, where light beams are visible because of the suspended particles in the air. You will the shape of the beam will be more natural and it will interact better with the scene. All this at the expense of more samples and rendering time.

enter image description here

$\endgroup$
  • $\begingroup$ Hi cegaton, thanks so much!! It seems to have worked. By add nodes I'm assuming you mean the add shader? On a slightly unrelated note, do you know why the closest light on the roof of the gas station is not emitting light like the rest of them? $\endgroup$ – Kenzo Caspian Burnett Mar 23 '18 at 8:12
  • $\begingroup$ because it is switched off for rendering (camera icon) $\endgroup$ – cegaton Mar 23 '18 at 13:52
  • $\begingroup$ Ah I see, silly me! $\endgroup$ – Kenzo Caspian Burnett Mar 23 '18 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.