0
$\begingroup$

I'm trying to put my render with a background image which worked the first time, but when I enlarged the resolution of the background image in photoshop to twice its size (from 4368 × 2084 to 8736 × 4168) and put it back in blender (and after doubling the size of the render resolution to match) the render is going off screen as shown in the pictures. How do I fix this?

Here's a link to screenshots: https://www.flickr.com/photos/163507419@N03/?

first one shows how I want it to look (this was when it worked at the 4368 × 2084 resolution), the others show what it looks like now

enter image description hereenter image description here enter image description hereenter image description hereenter image description here

thanks in advance

$\endgroup$
  • 2
    $\begingroup$ Please use this i.stack.imgur.com/jgAFv.gif to post screenshots as it will directly embed them and allow you to organize them in your question as well as ensure long term archival instead of an external link that may vanish. Also, if need be, attach your blender file using this: blend-exchange.giantcowfilms.com $\endgroup$ – Bruno Mar 22 '18 at 15:32
0
$\begingroup$

Without having your .blend and image files at hand, I can't tell for sure what is happening.

However, usually a "Scale" node (found under "Distort"), set to "Render Size" and applied just after the Image input, should guarantee that RenderLayers and external images have matching sizes. (Note: if the image is smaller than the render layers, it will be stretched, losing sharpness in the process)

enter image description here

I don't know, however, why they don't match already if – as you say – you already changed the resolutions in both the image and Blender. I can just suggest to check again.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi Nicola, I've added the blend file and images now, I'm about to check your method $\endgroup$ – Kenzo Caspian Burnett Mar 22 '18 at 16:08
  • $\begingroup$ Hi Nicola, your suggestion has worked! Thank you for your help $\endgroup$ – Kenzo Caspian Burnett Mar 22 '18 at 16:12
  • $\begingroup$ Hello Kenzo. Glad it worked! However, I've checked your blend file: be aware that you have opened the file "hi rez 2" into blender, but you are still using the original file (Gas station.jpg) in your "Image" node! I don't know what sizes these files are (they aren't packed into the .blend) but you might want to check which one you're supposed to be using! $\endgroup$ – Nicola Sap Mar 22 '18 at 16:14
  • $\begingroup$ Ah yes i forgot to do that as well! thank you for pointing that out too $\endgroup$ – Kenzo Caspian Burnett Mar 22 '18 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.