1
$\begingroup$

I have created 100 cube meshes from a Particle emitter using Ctrl+Shift+A. Then I have hidden the emitter.

However, when I try to play the animation, the new objects don't follow the Physics. By the way, all the generated objects have rigid body properties. So what am I missing here?

Attached the original blender file: link from Google Drive

enter image description here

$\endgroup$
1
$\begingroup$

If I understand correctly, you have originally assigned Rigid Body properties to your "reference" cube (the one that got duplicated by the particle system).

Even though this effectively assigns the Rigid Body properties to the child objects, it doesn't automatically add them to the RigidBodyWorld group, that is the group that the physics engine takes into consideration when baking dynamics (unless otherwise specified in the rigid body settings).

You can see that they are not part of a group by observing that their wireframe is not colored green.

There is a quick fix to this: select all your boxes and hit "Add active" in the "Physics" panel of the toolbox to the left of the 3D window.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.