1
$\begingroup$

I'm trying to bake a normal map from my high-poly meshes to my low-poly meshes, for the past couple of tries I've had the same result that is shown in the picture below

objects and normal bake

After about an hour of baking the map is empty of detail, there are only empty spots surrounded by blue. On the left hand side is my cage, in the middle my low-poly mesh and on the right, my high-poly mesh although with multiresolution modifier unapplied for now because my computer lags a bit when I have objects on 6 subdivisions.

I've tried multiple baking settings, remeshing the low- poly object, using cage, using a ray cast and nothing seems to work. I've had the same problem in my previous object but remeshing it fixed it, may it be caused due to the objects having multiple loose parts?

The gate, windlass and the rod above are all one object in my low-poly mesh, although in my high-poly mesh they are 4 different objects, one for vertical gate beams, one for horizontal gate beams, one for the windlass and one for the rod. I am selecting all 4 high-poly meshes and my low-poly mesh last.

$\endgroup$
  • $\begingroup$ See if this helps - blender.stackexchange.com/questions/103030/…. I don't think remeshing can prevent this from happening $\endgroup$ – Mr Zak Mar 21 '18 at 19:35
  • $\begingroup$ It did not help, I've already had this option checked. $\endgroup$ – Giddy_Up Mar 21 '18 at 20:17
  • $\begingroup$ Possible duplicate of Baked normal map comes out transparent $\endgroup$ – Alex Pensotti Mar 21 '18 at 21:13
  • $\begingroup$ I've already seen this thread and it has nothing to do with my problem. $\endgroup$ – Giddy_Up Mar 21 '18 at 21:32
  • $\begingroup$ There aren't really objects having too many (or too few) loose parts, just like too many subdivisions for the normal map. If you want someone to look into your problem in more depth share a blend file here blend-exchange.giantcowfilms.com and edit your question. Usually it's all about ray distance being cast from highpoly to lowpoly $\endgroup$ – Mr Zak Mar 21 '18 at 23:57
0
$\begingroup$

I think I have found the answer in another thread. I don't have a link to it but people there proposed that the missing normal map sections are due to too high multiresolution. I have lowered the multiresolution from 6 to 4 and it has baked fast and nicely.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.