I have created this with cycles:

enter image description here

But the edge between the glowing and non glowing materials is very sharp. The material was manually applied to faces in edit mode. Is there any way I can smooth the edge between them in cycles?


1 Answer 1


You can't really smooth the transition between two materials; materials are exclusively applied to faces and always delimited discrete pieces of geometry. Here are some alternative workflows:

Smoothing the transition between materials:

You can use a texture to mix the "materials", but everything is actually in one material instead, and different parts actually just use different shaders.

Use a wave texture as the mix factor of a mix node mixing the two node setups used to make the bright strips and the dark surface of the ball (everything is inside one one material datablock).

enter image description here

By using the Color Ramp node to adjust the falloff of the wave texture, you can control the sharpness of the transition.

Also see

#Other techniques:

Some other things which may make the transition a little more natural:

  • Using separate materials based on mesh topology (like in your question), extrude the faces with the emission material in a bit:
  1. Extrude (E)

  2. Cancel the grab part of the extrusion (Esc)

  3. Scale along the normals (AltS).

This may give a more natural looking separation between the two:

enter image description here

  • Use the Material Index Pass to create a bit of glare in the compositor:
  1. Enable the pass in Renderlayers > Passes

  2. Set the Pass Index of the emission material to a number that no other material has as its pass index (though we can use one index for all the different colors of the emission material).

  3. Set up the composite nodes (click for bigger image):

enter image description here

Make sure to set the ID Mask node to the same index as the material index defined before.

  • 2
    $\begingroup$ Never knew about the Alt-S trick. Thanks $\endgroup$ May 18, 2014 at 11:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .