7
$\begingroup$

I can't get vertex/edge/face snapping (or even grid snapping) to work in one blender file. I have tried this file in 2.79 and 2.79a. If I open another .blend file snapping works fine.

I have saved/closed/reopened the file, restarted Blender and rebooted the computer and upgraded Blender, all to no avail.

$\endgroup$
1
  • 3
    $\begingroup$ The link provided required to login. Instead, use blend-exchange.giantcowfilms.com to attach blender files. It will increase your chance of getting an answer and ensure long term preservation of your the files... $\endgroup$
    – Bruno
    Commented Mar 19, 2018 at 22:22

9 Answers 9

13
$\begingroup$

Well, I compared with another file, setting-for-setting, until I found the answer. It turns out that in the 3d-view header (in edit mode) there is a button for "Proportional Editing Mode"

demonstration

and when I set that to "disabled" then snapping started working again. I have no idea what I did to enable that (probably accidentally pressed some obscure key combo). I searched all over the Interweb for this issue and although I found a bunch of folks with the problem, nobody offered this "solution". I hope this helps the next poor soul that has this issue.

$\endgroup$
4
  • 1
    $\begingroup$ If you think about it how you ca not snap to something when it is being moved away from you. Proportional Editing and mesh snapping can not work together. $\endgroup$
    – David
    Commented Mar 20, 2018 at 13:31
  • 1
    $\begingroup$ Yes. The "sphere of influence" was very small and I didn't notice that proportional edit mode was turned on. Newbie mistake. $\endgroup$
    – JesseChunn
    Commented Mar 20, 2018 at 15:58
  • 2
    $\begingroup$ You probably hit O by accident $\endgroup$ Commented Mar 20, 2018 at 16:47
  • 1
    $\begingroup$ It would be great if when you first hit 'O', the radius of influence defaulted to your current selection.. the number of times I've lost track of it ... $\endgroup$
    – Robin Betts
    Commented Aug 29, 2018 at 11:07
4
$\begingroup$

Had this problem but it was snap to self icon was turned off, on the right of vertex snapping options, the 2 little squares icon.

$\endgroup$
2
$\begingroup$

Make sure Project on to Self is turned on in the Snap dialogue.

$\endgroup$
2
$\begingroup$

If snapping doesn't seem to work at all, no matter what setting is turned on, just remember that the snapping starts at your cursor, not at the edge of the object.

So if you grab the object at its middle (which is what I did), snapping will not happen until you bring the cursor up to meet the snap target, at which point the two objects might be intersecting:

Bad cursor placement

So remember to grab the object by the point you want it to be snapping at:

good cursor placement

$\endgroup$
0
$\begingroup$

I just turned clipping off and on again and that fixed it. I was using a mirror modifier at the time so don't know if that helps anyone else, but it worked for me! Still using 2.79 too.

$\endgroup$
0
$\begingroup$

I worked on file & it was fine, but next time just couldn't add any points to the curve on the mesh below. I had the 'Projection Depth' accidentally set to 'cursor' instead of 'Surface'. Couldn't draw any points on the mesh below. Just in case this helps someone.

$\endgroup$
0
$\begingroup$

I have the same problem and I resolve him like that : in edit mode select "tweak" . After that this "snap" works fine.

$\endgroup$
1
  • 3
    $\begingroup$ Could you explain better how to achieve this? Perhaps describe the steps in detail, and show a screenshot of the results $\endgroup$ Commented Jan 6, 2021 at 13:23
0
$\begingroup$

In case someone else still has this problem and none of the other solutions worked, try an orthogonal view. I didn't change any of my settings, it just didn't work from time to time. In those times it still worked in orthogonal view. I have the theory that my scene was too big with several 100 meters

$\endgroup$
-1
$\begingroup$

I had this problem in Blender 3.3.

To solve it, I needed to select the Affect > Scale option, within the Snap To popover, next to the Snap toggle. It was previously unselected.

Snapping Modal View

$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .