1
$\begingroup$

2018-03-25: As suggested in the comments inserting the project as a scene strip in a new scene tab allows you to adjust the mastervolume of the entire scene like in render options. You can then mixdown. Mixdown did not skip any keyframed audio clips or distort/clip using this method. seems to be the best workaround atm in the ui. I'm going to be capturing in audacity though instead I think, just cause it feels more like what I edited that way.

2018-03-24 edit: Sent bug report for the audio clipping problem, unable to produce .blend sample of the keyframed audio missing at this time.

2018-03-24 edit upload: This is of the first problem where 1 strip is set to the default 1.0, the 2nd at 10.0. Then both are ontop of eachother. Point is: if you mixdown this and put it in audacity you'll see mixdown clips the higher volume one, how to not do that... I couldn't reproduce and upload a copy of the keyframed audio skipping/notplaying. oR I could, but i couldn't upload it.

2018-03-022 re-edited:

What I hear on playback in the vse is now different from what I get after I render.

When I mixdown just audio, setting accuracy to 1 (normal setting creates 'more' distortions), the waveform output is clearly clipping when viewed in audacity compared to the waveform of the captured playback in the vse (aka mixdown is amplifying so much it distorts; See picture 1). There are also missing audio strips, potentially due to the clipping. Having audio strips set to low values, in their individual n-tab, like making the 1.0 value the midrange of my audio (the default), makes it avoid clipping. For example I had a strip set to 10.0, doing mixdown it was distorted and horrible sounding like in picture1. Upon changing the value to 1.0 tho, it sounded the same way as it did when I captured it in the vse playback via audacity. I also couldn't find any missing strips so far via this method. The only difference was the waveform was amplified a bit differently (aka a bit quieter), but this can be fixed in audacity if necessary.

VSE playback is the first waveform (sounds great). Mixdown in .wav/.flac is the 2nd/third waveforms (loud/distorted) figure1

Now the other route to getting audio rendered... When I render audio alongside video (normally), the problems are similar to the mixdown, only I can set the master volume lower (the bar in audio options that is set to 1.0 by default; I set it to 0.1) and the waveform output doesn't clip but everything is really quiet and you have to turn ur volume up to hear normal levels (the output is NOT clipping tho, which is good). Okay...so far so good. However:

1. I don't know what amplification/volume its rendering at in comparison to what I hear on playback in the vse. Trial and error required to get a grasp. So I don't know what value to set the mastervolume to perfectly avoid clipping while keeping the volume as high as possible.

2. Some audio strips do not render at all for some reason regardless of master volume settings. Those with keyframes specifically. Some with keyframes render fine though. Rendering "just" (or smaller sections, to the extent I don't know) the specific section with the keyframed audio pieces tho solves the problem for some reason.

So based on this the following workarounds can be done:

Workaround 1: I can playback everything in the vse, and capture it using audacity and use that as my audio file. In the image below I deleted EVERYTHING except my audio strips so playback would be smooth (even if I set it to av-sync, audio can stutter with too much stuff in the vse). Infact this is a good summation of the problem and what I need to do:

I need to mix all this audio down so it isn't clipping/distorting/missing: problem is it sounds fine as is in the vse playback, but after rendered it is infact clipping/missing/distorting audio strips.

enter image description here

Workaround 2: If I go in and lower the strip volume options individually so they are all lower values (I have to try to make the mid range around the 1.0 volume values). Then this enables me to mixdown, thus creating a version that doesn't have the clipping and doesn't have missing strips (as far as I can tell anyways). However this is a ton of work given the project is 25 mins of many many audio strips, to be individually reset/mastered (see picture above). Plus I still don't know what level of amplification mixdown is applying, so i can only make a copy of an amplification that doesn't clip that will need to be amplified in audacity afterwards (which isn't that hard to do).

Workaround 3: Divide the 25 mins up into 60 second intervals, and render the video/audio together out bit by bit then reform and do a final render. Very lengthy process though and no guarantee it will work in 60 second intervals, might have to do less.

Closing thoughts: If there was a method of changing the mixdown volume/amplification (to prevent it from going so loud its clipping)....that would create a solution and I could just mixdown audio and video separate and recombine later. I just want the thing that plays in my vse....to sound the same as the thing it renders out as. Audio mixdown seems to offer the only solution I can find in blender's immediate ui, since normal render is missing strips when I render more than small portions. But this will require, for future projects, making sure my volume is super high when working in the blender VSE, to ensure I avoid clipping. I would then use audacity to finetune the amplification/volume levels so the mid range is the same as other videos.

Regardless I need blender to do apply "What you see/hear is what you get" in order to continue using it as a video editor for anything involving more than singular audio strips. So is this a bug I won't have to deal with again or a limitation? I guess is the future question.

$\endgroup$
  • $\begingroup$ changing the accuracy seems to help. I set the accuracy to 1 and it was good for a small segment. Then I set it to just under 2000 and it clipped and went bad for alot of it like the problem originally. So I'll try mixing down the entire thing with 1 accuracy. I don't know what that means or does tho....can't find anything in the online manual of use. I heard you can mixdown audio and video in vlc so ill try that mbe, render with no audio....mixdown...then combine in vlc? Is there a better program to combine audio and video files? $\endgroup$ – kite Mar 19 '18 at 22:03
  • $\begingroup$ Consider transcoding the media to a more blender friendly format? $\endgroup$ – 3pointedit Mar 19 '18 at 22:04
  • $\begingroup$ i don't understand any of that. Can you elaborate? what would be a blender friendly format? most of the audio strips r .wav 16, some are mp3 $\endgroup$ – kite Mar 19 '18 at 22:05
  • $\begingroup$ Oh I thought that you were using audio from video files, like mp4. They can be troublesome as the frame rate is calculated differently for video than for audio (technically audio uses sample rate not frame rate) and they can get a bit muddled. I think your best bet is to try accuracy. It will spend more time converting off sample rate media to your project settings. $\endgroup$ – 3pointedit Mar 19 '18 at 22:11
  • $\begingroup$ ya these are all separate audio files I subbed in, aka I had VA do them and I sub them as strips on the video frames and manually sync. Do you know what the difference between the other options are tho? for .wav it has signed and floating point...idk what the difference is. what is better quality? .flac only has up to S24. wav has up to F64. which would be better to try for the entire 30 mins of audio clips? Most of the audio strips in there are .wav alrdy. But I can render the video and audio as .flac and not .wav in render options....or i can just combine after with vlc or something else $\endgroup$ – kite Mar 19 '18 at 22:14
1
$\begingroup$

As a workaround (to an apparent bug) you can send the "mixed" scene to another VSE timeline using a scene strip. In the new "master" Scene the old "mixed" scene's strip will allow you to make a global change to volume. But you will have to enable the button "Use Sequencer" in the scene strip properties.

scene strip volume properties

Then you can bring the volume down to a value that won't distort or clip.

You will have to render from this new "master" scene.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.