0
$\begingroup$

I've been importing overwatch maps into blender which has worked well in the past. I have used something called OWimporter which is a tool that extracts data from files such as .owmat,.owmap, and .owmodel. Now when I open my file I press space and type ".owmap" and I fetch the file from my directory. Now, I am using a GTX 980TI gpu and CUDA is enabled (as it should be). I set the render set to cycles render. Then I test all the materials for switching into material mode. As you can see... Everything is here: enter image description here Now I decide to go into viewport render and BOOM: enter image description here The lighting and object orientation are all in place but the textures and materials seem to be missing. If I go into node editor for any of these objects I can see that there is something connected to material output (obviously).The next thing I tried was pressing ctrl + alt + H to de-restrict render. What this means is that for all objects that were not suppose to be fully rendered in the final render,are now visible. I though this would solve it, but it doesn't. I do however believe that the solution to my issue has something to do with the fact that some parts are just not getting rendered out properly due to them being blocked by something or another. Lastly, on occasion, I keep seeing "cuda error at cudamoduleload: file not found blender" and it just completley stops all rendering processes. I know I have enough Vram so I really dont know what is going on. But IDK that is why I am here! If you guys have any idea of what is going on please feel free to post a response! Thanks!

UPDATE: enter image description here AS You can see, it is a CUDA error and there are missing textures. Now, the problem with all this is that I cannot seem to "report missing files" and when I click "find missing files" I give it the entire folder to sift through. However, there are no material files! IDK why and if there were, they would be in this .owmat format. Which blender does not go out and find cuz its not a base file type. I had to install a addon to read these type of files. here is another file as requested: enter image description here

Lastly here is anouther post I made with a video of me going through all the processes: NOT THE USUAL textures and materials missing in view port and final render from imported scenes

Here is another blender file I tried and I think I found the problem: enter image description here look at the preview. NOTHING...

$\endgroup$
  • 2
    $\begingroup$ That does not look like an issue with CUDA. Pink means missing textures. This could be because the textures are in a directory that is not available or they have been moved somewhere else. Use File > External Data> "Find missing files"blender.stackexchange.com/a/96607/1853 $\endgroup$ – cegaton Mar 19 '18 at 18:59
  • 1
    $\begingroup$ Given that this is an imported object, it is likely that the materials for cycles are not created correctly (maybe they were created for blender internal) or the mapping for the images in the textures is incorrect or the UV maps are messed up. Evaluating materials in material view when using cycles will never give you a proper idea of how the shaders are working. Please add more information to your question and also add images that show some of the material nodes. $\endgroup$ – cegaton Mar 19 '18 at 19:11
  • $\begingroup$ I have updated my post $\endgroup$ – gengas Mar 20 '18 at 8:07
  • 1
    $\begingroup$ There should be more information about that CUDA error in the blender logs (try pulling down the top menu bar). Also, I see something similar in case of a missing world environment texture $\endgroup$ – remco Mar 21 '18 at 6:59
  • 1
    $\begingroup$ could you upload your blend-file to blend-exchange.giantcowfilms.com? that would help. Or at least upload screen-shots of the content of the node groups (you can enter node-groups by selecting them and pressing tab $\endgroup$ – bstnhnsl Mar 21 '18 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.