0
$\begingroup$

I have my blend file at pasteall.

Whenever I try to render the scene with no render layers selected, it says All render layers are disabled and then does nothing. This is as it should be.

However, whenever I try to render the scene with any render layers enabled it seems to utterly ignore the render layers and render whatever is visible in 3D view instead.

Better yet, the point light I've put in does . . . nothing.

I'm actually working on a real piece, and I did this experiment in parallel with it (I want to do some symbolic artwork about the internet/information exchange using Blender.), and I'm afraid of something like this happening to actual work.

Thank you very much to anyone who can illuminate this!

P.S.: I have this idea working in several other blend scenes, it's just this one with which I've made a problem for myself.

$\endgroup$
  • $\begingroup$ The renderlayers seem to be working exactly as expected for me.. $\endgroup$ – gandalf3 May 16 '14 at 21:09
  • $\begingroup$ I'll go over it again, in great detail, and see if I can reproduce the expected results. It's not just the lamp... blender seems to be ignoring my selection and just rendering what is in the 3D view. I'll restart my machine in case there was a memory leak or something arcane..... $\endgroup$ – user1833028 May 16 '14 at 21:12
1
$\begingroup$

The reason that your point lamp has no effect is that the plane below it is 100% glossy. Lamps will not appear in reflections if they do not have multiple importance sampling enabled. Also see How do you make a lamp light up glossy surfaces?

The other objects have emission materials, which will appear shadeless (will not be affected by light sources).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.