2
$\begingroup$

I was playing around with Glass BSDF shader to see what it look like and how it interacts with its environment. Bellow, you can see a test scene.

Previewtest render of a cube sphere and suzanne

Final enter image description here The preview render on the sphere looks fine but when a final render was done the refraction of the checker-board was pixelated and distorted. The final render was done with 400 samples. Is that too little or am I missing something. Is there a way to improve render quality of the refraction in the glass sphere?

File here :

$\endgroup$
  • 2
    $\begingroup$ Are you using flat shading on the sphere and suzanne? Can you upload the scene, e.g. on pasteall.org? $\endgroup$ – B.Y.O.B. Mar 18 '18 at 22:32
  • $\begingroup$ @B.Y.O.B. here is the url pasteall.org/blend/index.php?id=49181 Sorry, new to this and not sure what you mean by flat shading. $\endgroup$ – Dzyuv001 Mar 18 '18 at 22:46
  • 1
    $\begingroup$ @B.Y.O.B. in pasteall the links expire after a few months. For permanent links use blend-exchange.giantcowfilms.com $\endgroup$ – cegaton Mar 18 '18 at 23:17
  • 2
    $\begingroup$ Select the sphere, go into edit mode (Tab), press W, click "Shade Smooth" and render again. @cegaton Good point. edit: looking at the .blend, the subsurf modifier is set to 4 in viewport and 2 in render, that's why it looks ok in viewport (the high subdivision hides the flat shading) $\endgroup$ – B.Y.O.B. Mar 18 '18 at 23:23
  • $\begingroup$ @B.Y.O.B. thank you, it worked. I will edit the port with a permanent link. $\endgroup$ – Dzyuv001 Mar 18 '18 at 23:55
4
$\begingroup$

The problem is that you are using flat shading on the mesh, as opposed to smooth shading that interpolates normals: https://docs.blender.org/manual/en/dev/modeling/meshes/editing/normals.html?highlight=smooth%20shading#shading

The reason why it looks ok in the viewport is that your subdivision surface modifier is set to 4 iterations for the viewport and 2 iterations for the final render. So the high subdivision in the viewport hides the flat shading.

Solution: Set viewport subdivisions equal or lower than final subdivisions, and enable smooth shading on the mesh (see above link).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.