0
$\begingroup$

I'm doing this tutorial: Blender smoke animation

and when I go to bake before doing lighting and stuff it gives me an error that says "Object cube is not on a scene layer". I did parent some UV spheres to the cube and that probably has something to do with it. Here is a screen shot of my layers and outline editor. I hope I'm showing what the potential issue is in the screen shot. Is there a way I can bake these objects with still having a parent object?

I've tried looking on google and forums, but can't seem to find the answer. Thanks!

layers and outline.

$\endgroup$
1
  • $\begingroup$ Try exiting Local view (Numpad /) and see what scene layer is that cube on $\endgroup$
    – Mr Zak
    Mar 17 '18 at 16:49
1
$\begingroup$

First of, as you can see in the top left corner of your viewport, it says "Local", which means you're in an isolated mode. You probably enabled it accidentally by pressing numpad / or it was on purpose but you didn't though about getting out of it when not necessary anymore.

Anyway, start by pressing numpad / again, that may already be the solution. If not enough, you may now see your 3D view layers :

3d view layers

And most importantly: which one you're in, which one you have the active selection in and which ones contain objects. From that, you will quickly determine if you need to move some object around. To move some objects to another layer, simply select the objects and press M.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.