2
$\begingroup$

In Blender I can simply exclude node from a node tree with Alt+RMB, but with "Node Wrangler" addon the "Alt" key is used for Mix node.

How can I exclude node from tree with "Node Wrangler" enabled? Thanks

enter image description here Another example – that I can't do with Wrangler enabled. enter image description here

$\endgroup$
  • $\begingroup$ I use Ctrl + LMB and draw a circle around the node. $\endgroup$ – brockmann Mar 16 '18 at 15:38
  • $\begingroup$ ... but you loose a string. You have to reconnect it manually. $\endgroup$ – vklidu Mar 16 '18 at 16:28
1
$\begingroup$

There is Detach From Outputs function which does that, also leaving inputs of the node you moved out from the tree attached. Press Shift+Alt+D with node to detach:

gif-image

Or from the Node Wrangler toolshelf (N in the UV editor, Node Wrangler tab):

enter image description here

$\endgroup$
  • $\begingroup$ Thank you for help. If this is the addons way I will try to remap shortcuts. $\endgroup$ – vklidu Mar 16 '18 at 17:02
0
$\begingroup$

Alt+D - detach node from all inputs and outputs

enter image description here

(Works in blender 2.79 or 2.8x as default function, no conflict with Node Wrangler if enabled.)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.