3
$\begingroup$

I use ctrl+click a lot to quickly select segments of edge loops in edit mode, but sometimes this results in accidentally clicking other objects outside of the one I'm editing (which means I've selected both the object I'm editing and some other object).

This gets kind of annoying because it interferes with my view any time I switch to wireframe viewport mode, not to mention I don't want to later accidentally affect objects I didn't notice I selected.

Is there any way to prevent selecting objects while in edit mode?

$\endgroup$
  • $\begingroup$ Change the keyboard shortcut to not select objects, or assign it to a different key $\endgroup$ – Duarte Farrajota Ramos Mar 14 '18 at 18:49
  • $\begingroup$ @DuarteFarrajotaRamos Ah I didn't even think about changing the shortcut. Thanks! $\endgroup$ – Jace Cotton Mar 14 '18 at 18:56
  • $\begingroup$ Also, if you have an Object that is made up of more than one Object in Edit mode you can select them all and press "P" > By Loose Parts. This will make them separate objects. You can join them together again by selecting them in Object Mode and pressing CTRL + J $\endgroup$ – Dontwalk Mar 14 '18 at 19:02
  • $\begingroup$ One workaround is to enter Local view with Numpad / for the object you edit. However this isn't the case when doing retopo. As to me this should be reported as bug / limitation since Edit mode for the mesh shouldn't be affected by any other objects not being part of the object Edit mode is enabled for $\endgroup$ – Mr Zak Mar 14 '18 at 19:18
1
$\begingroup$

Select linked (Ctrl>+L) to select vertices/edges/faces linked in the current object and then press Shift+H to hide the unselected vertices.

Hidden geometry cannot be selected or edited.

When you are done editing press Alt+H to Unhide.

Consider also creating Vertex Groups to simplify the selection/hinding process of different parts of your objects.

$\endgroup$
  • $\begingroup$ I'm talking about accidentally selecting other objects, not unwanted meshes within an object I'm in edit mode for. Perhaps I should have shared screenshots to clarify this. Although you did mention hiding stuff I don't want selected so that could apply to other objects as well, though I think I'll just change the shortcut as Duarte suggested above. $\endgroup$ – Jace Cotton Mar 14 '18 at 18:56
  • $\begingroup$ select an object pres numpad / to enter local view. All unselected objects will be hidden. $\endgroup$ – cegaton Mar 14 '18 at 19:52
0
$\begingroup$
  • You can hide the objects before you enter Editmode with H

  • you can switch to local Mode and only your selected objects will be visible (view >> View Global/Local).

  • you can click the little arrow in the Outliner next to the troublesome objects and they won't be selectable. Doing it with an ALT Click will disable selectability for all selected objects. Switching them back on is harder because, well, you can't select them.

  • you can draw a clipping border around your object with ALTB. If it hides the other objects, problem solved.

  • You should be able to deselect the option in the keymap editor, but I just can't find it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.