2
$\begingroup$

Blender 2.79 I'm trying to follow a Cycles workflow in baking out normals from a high poly mesh to low. Instead of a purple image with rainbow detail I'm getting nuthin.

  1. I've checked both meshes' normals. They're all facing the right way.
  2. A 2048 image was created for the normal bake and selected in the materials editor. It's not hooked up, but that shouldn't matter - so long as it's selected and targeted.
  3. No modifiers are on either mesh. No subsurfs, nuthin.
  4. Ray distance only seems to work on 0. Anything higher and the result is as the image shows.

What are your best guesses? I've had this happen before, and I found starting over again worked. I don't want to have to keep re-starting models.

2-frame GIF showing ray change. Click to expand

$\endgroup$
  • 1
    $\begingroup$ Could you include a testing file with the problem shown on blend-exchange? I see this problem gets asked last time but I couldn't reproduce it $\endgroup$ – Mr Zak Mar 13 '18 at 11:14
  • $\begingroup$ It's most definitely the ray distance. Try setting it to 1. Otherwise it's hard to tell without the file. $\endgroup$ – metaphor_set Mar 13 '18 at 14:18
  • $\begingroup$ I don't get how it even works for you as it just shuts down for me when baking, but you disabled rendering surfaces for the render layer which objects are on. Though I've no idea how is this related with transparent normal maps working on nearly 0 ray distance only - this isn't that clear $\endgroup$ – Mr Zak Mar 13 '18 at 21:20
2
$\begingroup$

EDIT 2: FIX

Ok After some crazy amount of testing I found the culprit :D Check Use Suface

In the render layer section, you have to check in EVERY render layer "use Surfaces". If unchecked, you will get this strange transparent section in GPU Mode.
And in CPU mode it will even cause a crash to desktop.

In my opinion this crash is even worth a bug report.

$\endgroup$
  • $\begingroup$ Tried that - no joy. Just get different shaped transparent hole. Cage doesn't work - I get a error, that the two objects must have the same number of faces... which is kinda silly. $\endgroup$ – OroNZ Mar 13 '18 at 10:24
  • $\begingroup$ Amending last comment: Tried cage (properly this time, I think): still no joy. $\endgroup$ – OroNZ Mar 13 '18 at 10:33
  • $\begingroup$ then, have you checked if all your normals are pointing in the same direction? $\endgroup$ – monatsend Mar 13 '18 at 15:36
  • $\begingroup$ 3. I've checked both meshes' normals. They're all facing the right way. (That is, all normals are radiating outwards from faces.) $\endgroup$ – OroNZ Mar 13 '18 at 18:53
  • $\begingroup$ Do you mind sharing your mesh? Then I can try to find the issue $\endgroup$ – monatsend Mar 13 '18 at 18:54
1
$\begingroup$

(Monatsend found a key part of the issue. I'm just adding this simple scene file you can test things with, and a link to a video that explains the bug... Because there's more to it.)

Baking Normals in Cycles successfully requires users to check several things in different areas. Basically, baking normals is a hack, rather than a workflow, so you have to stay on your toes.

Monatsend's right: 'Use Surfaces' needs to be checked, or normals can't be baked. However, if you accidentally create a 'transparent normal' image, you can't go back from that. Something breaks. You'll need to restart Blender.

Link to an explanatory video: https://vimeo.com/261681317

Normal Cube.blend:

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.