2
$\begingroup$

I'm running into a strange situation in Blender, where reflections show up nicely in Preview, but not in the final render (using Cycles). What could be the cause of this?

Preview: enter image description here

Render: enter image description here

here are my settings for Cycles: enter image description here

and my blue, glossy material: enter image description here

Is there some settings I'm forgetting about?

Here's the file:

$\endgroup$
  • 1
    $\begingroup$ not sure why this is, under "light paths" try changing the drop down to "Full Global Illumination" and see if that fixes anything. If so, then you may not have had enough light bounces. If not try changes the clamp direct and indirect to higher numbers (around 15) $\endgroup$ – icYou520 Mar 12 '18 at 21:04
  • 1
    $\begingroup$ Check also if there's anywhere lamp available for preview render but not final one. $\endgroup$ – Mr Zak Mar 12 '18 at 21:14
  • $\begingroup$ I tried your suggestions, but it didn't help. This is still a mystery to me... I added a .blend file, in case that would help solve this problem. Thanks a lot! $\endgroup$ – Rodolphe Mar 13 '18 at 14:04
  • 2
    $\begingroup$ When sharing your .blend file please pack the images used as textures $\endgroup$ – cegaton Mar 13 '18 at 15:08
  • $\begingroup$ Oops, sorry about that (and thanks for letting me know)! in this particular case, we are only missing a colored texture (the blue shade), but (I hope) this doesn't change the reflection issue. $\endgroup$ – Rodolphe Mar 13 '18 at 15:21
1
$\begingroup$

This is caused by the simplify option in the scene-tab (at the bottom of my screenshot). simply disable it and you're good to go. you can also set the "AO bounces render" to 0 if you want to use other options of the simplifier (simplify subdivisions etc.). This option limits all non-diffuse bounces (0 = no limit)

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.