3
$\begingroup$

I wonder whether cloth self-collision works. I created a cloth with two materials and folded them like the first picture. I started cloth simulation, whose self-collision distance is 0.75. The cloth became strange like it in the second picture.I tried different self-collision distance, but it didn't work well.... Let me show four sets of experiments. I need cloth self-collision in my clothed avatar. Cloth self-collision doesn't work well as I think. Penetration or repel happens on pocket, collar or hip where shirt and pants (they are one mesh object) overlay.

Experiment 1: Large cloth dropped to a cube with 0.75 distance on Self-Collision. The result looks good, but the beginning is not.A folded cloth dropped to a cubeThe beginning stateThe setting for the clothThe final result

Experiment 2: Large cloth dropped to a cube with 0.55 distance on Self-Collision. The result looks bad, but the beginning is good.enter image description hereenter image description hereenter image description here

Experiment 3: Smalecloth dropped to a cube with 0.75 distance on Self-Collision. The result looks good, but the beginning is bad.enter image description hereenter image description hereenter image description here

Experiment 4: Small cloth dropped to a cube with 0.55 distance on Self-Collision. The result looks bad, but the beginning is good.enter image description hereenter image description hereenter image description here

$\endgroup$
  • $\begingroup$ Have you tried Apply Scale? If this doesn’t help, can you share more details of your setup? Eg, show your mesh in Edit mode to show the geometry. $\endgroup$ – Rich Sedman Mar 12 '18 at 6:35
  • $\begingroup$ I updated the questions. Scale are applied. Does the mention work? It doesn't turn blue in my commend. :( @RichSedman $\endgroup$ – 萌香ちゃん Mar 12 '18 at 14:21
  • $\begingroup$ Thanks for the additional detail - that really helps to understand the issue. You should be able to have the Self Collision Distance low without ill effect. Most likely the problem is due to the quality of the simulation - try increasing the Cloth Quality Steps from 20 to, say, 200. This will slow down the simulation as it will have more work, but should be more accurate in the sim. If it helps but still not perfect then try increasing even further and/or try increasing the Cloth Collision Quality settings and see how that helps. $\endgroup$ – Rich Sedman Mar 12 '18 at 14:54
  • $\begingroup$ The maximum of Cloth Quality Steps are 80 and that of SelfCollision is 10. Still can't get a good simulation. Do you know how people deal with cloth with pocket or collar in the physics simulation? @RichSedman $\endgroup$ – 萌香ちゃん Mar 12 '18 at 15:04
  • $\begingroup$ I’m not all that familiar with tuning cloth as I find Soft Body to be more generic and adjustable. I’ll see if I can replicate your settings and behaviour and try and provide a solution. $\endgroup$ – Rich Sedman Mar 12 '18 at 18:07
1
$\begingroup$

The cloth self-collision is affected by the scale of the faces making up the cloth. This means that when you have a fairly coarse level of subdivision the self-collision Distance will result in a cloth that is quite separated whereas if you subdivide the mesh more finely the cloth is permitted to get closer before colliding. Since you only have a single face-width between your folds the self collision is forcing the sections apart in your first example, resulting in the cloth being blown out into the unnatural shape.

The solution is therefore to simply add more subdivisions. This will result in the scaling of the self-collision to be more appropriate and will also produce a more natural behaviour of the cloth - but this will also significantly affect the simulation time.

To demonstrate this working, here's my subdivided example mesh :

cloth sim

I first ran the simulation with lower subdivision and a Self-Collision Distance of 0.55. This resulted in overlapping faces as in your second example. Using a high Distance also caused the cloth to 'blow out' as in your first example.

However, the higher subdivisions allow the Distance to be left at the default value of 0.75 without the cloth being 'blown out' while also preventing it from self-intersecting. In addition, the cloth was allowed to collide quite close together so there is not a significant gap between the layers. This produced the following result :

final result

This was produced with the following cloth settings :

cloth settings

If you still have intersection issues (particularly from fast moving collisions) you may need to increase the Cloth Quality Steps and/or the Collision and Self-Collision Quality settings (this will also slow down the simulation).

$\endgroup$
  • $\begingroup$ Thanks for your help. I tried it in my clothed avatar. With a correct setting, the collar and hip look good. I have one more question, can Blender handles 2 or more layers cloth simulation? I dropped two or three clothes on a cube before and got a bad result. @RichSedman $\endgroup$ – 萌香ちゃん Mar 13 '18 at 1:34
  • $\begingroup$ Glad to help. Please start a new question for the multiple layers of cloth. $\endgroup$ – Rich Sedman Mar 13 '18 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.