10
$\begingroup$

I have several videos in the blender sequencer (2.79). When I select FFMPEG Video in "Output", the error "The encoder timebase is not set" appears. I tried every container and codec combination.

Thanks for your help!

$\endgroup$
17
$\begingroup$

I had to change the frame rate from 23.8 to 24 to back to 23.8 fps....

$\endgroup$
3
  • $\begingroup$ For those new to Blender, this is in "Properties" View -> "Render" (the camera icon) -> "Dimensions" tab $\endgroup$
    – Joshua H
    Dec 9 '18 at 16:28
  • 1
    $\begingroup$ This was actually a bug in Blender, which I just fixed. Things like this can be reported in the bug tracker. The fix will be part of the 2.80 release. $\endgroup$
    – dr. Sybren
    Jun 11 '19 at 13:54
  • $\begingroup$ Wow this is a serious bug that kept me from getting rendering working for hours. Thanks @BobBlndr. $\endgroup$
    – moodboom
    Jan 24 '20 at 14:09
6
$\begingroup$

I had the same problem in Blender 2.8 and found that the video I imported set a custom frame rate. Once I changed it by selecting the frame rate it worked.

$\endgroup$
1
  • $\begingroup$ That has solved the issue for me. Hadn't realized it got changed to "custom", changed it back to what it was supposed to be and it worked. Thanks! $\endgroup$
    – Frieke
    Jan 29 '19 at 20:49
3
$\begingroup$

You have to set the fps by an aproximated value in the list predefined by blender. That was my solution.

$\endgroup$
1
$\begingroup$

I had the same issue. Solved it by exporting the video in RAW AVI format and sound in wav format separately. Then I imported them as two strips (Audio + Video) and re-encoded them into MP4 using the exact same settings. That seemed to work after a night of sleeplessness...

$\endgroup$
1
$\begingroup$

I am pretty sure this has to do with the inherent difficulty in dividing floats (numbers with a decimal point) in computer software.
When you insert your first video clip into blender, it auto-detects your fps and sets it for the entire video.
This usually translates into what blender calls a custom fps, which takes the top number and divides it by the bottom number to determine fps. (this can be found under the render presets in the Properties view) Sometimes it puts weird numbers in there that cause the result to be an infinite number like dividing 10 by 3 which results in 3.333333...

To fix it, you can just tweak the numbers in the custom fps setting.
For example if your Custom fps was calculated to be 29.92, you can put 2992 in the FPS: field and 100.00 in the /: field. The result will be 29.92 again, because 2992 divided by 100 is 29.92. Then it will work.

$\endgroup$
1
  • $\begingroup$ This worked best for me. After a lot of editing, cutting, stitching and adjusting pieces of a video, I finally pressed "Render" and got that "encoder timebase" error. Changing the fps to something else would mess up positions of the pieces of the video, and changing it back wouldn't restore the correct positions. My auto-detected custom framerate was 59.95, FPS 32767, Base 546.58. Changing Base to 100, then FPS to 5995 fixed the timebase problem without messing up the pieces. The order mattered, if I change FPS first, Base second, audio length would become incorrect. $\endgroup$
    – Headcrab
    Nov 19 '20 at 13:19
0
$\begingroup$

I had the same problem and couldn't solve it for days, but I finally figured out the trick. Apparently, if you let blender set the framerate when you import the video, it doesn't always get the correct ffmpeg settings. So, even if the framerate is set to the correct framerate, try setting it to something else, giving it a quick render, and then setting it back manually to the original framerate you were trying to render with.

$\endgroup$
1
  • $\begingroup$ More specifically, the framerate that was set was 30.0. I ended up changing it to 30. It may seem the same, but it's different enough to throw this error. $\endgroup$ Dec 12 '18 at 12:44
0
$\begingroup$

This was actually a bug in Blender, which I just fixed. Things like this can be reported in the bug tracker. The fix will be part of the 2.80 release.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.