1
$\begingroup$

I'm aware that blender units is the default in Blender. And, I think I've changed everything to metric where necessary.

In Scene: Units is set to Millimeters Length is set to Metric Unit scales is set to 1.0 (though I don't fully understand the function of unit scales)

Then, I have (for example) a simple cube with x/y/z of 40mm. [edit] meant to mention that I also scaled the model back to 1 with CTRL-A - Scale, so that everything is at a scale of 1

I export the file to .STL, but when imported in to Slic3r it always comes in as .04 mm (4/100th mm).

I've imported items from thingiverse, and they import to the correct sizes. So, I'm 99.9% sure this is a blender configuration issue. Anyone know what I'm missing?

$\endgroup$
  • $\begingroup$ "In Scene: Units is set to Millimeters" Never used slice but this is most likely the issue, most things expect scene units to be in Meters $\endgroup$ – Duarte Farrajota Ramos Mar 8 '18 at 20:30
  • $\begingroup$ Still having issues. The file I downloaded from thingiverse that imports to Slic3r as 80mm x 10mm x 11mm (which is the correct size) imports to Blender by a factor of 1000x--that is to say It's importing mm as m. And, this was with your suggestion to use scene: meters. $\endgroup$ – James Mar 9 '18 at 3:23
  • $\begingroup$ just found a possible solution on another forum; another user said he had to scale files imported from blender by 1000. This seems to work, because nothing I change in blender seems to make a difference. Scaling in Slic3r works--though not ideal. $\endgroup$ – James Mar 9 '18 at 3:34
1
$\begingroup$

By default, 1 Blender unit = 1 mtr, as evidenced by default gravity value in the scene settings.

You could try setting the scene unit to Centimeters (1 unit = 1cm), then scale accordingly. Make sure to enable "Scene Units" in STL export.

For me, leaving the scene at blender units and for STL export enabling "Scene Units" and setting the scale to 10 works fine. For me. For me, this equates to 1 unit = 1cm

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.