2
$\begingroup$

I'm trying to do motion tracking for a clip but it can't track past a certain point. The trackers all go red and I can't figure out why. Any help would be greatly appreciated, thanks!

Tracking markers going red

$\endgroup$
5
$\begingroup$

The tracking process stops when blender cannot accurately track an element. In other words: tracking fails when the tracked element cannot be found accurately within the search box area.

This can be because the element has moved too much and is outside the search area, or because is blurred, deformed, occluded or too close to the edge of the frame. The tracking process also stops when it has reached the last frame defined for the scene (or the first one if tracking backwards).

What are the blue and red lines?

When you track there is a path created showing the motion of the tracked element across the frame.

Red indicates motion on the previous frames, blue is for the path on future frames.

If you track forwards you will see a red track being created. If you track backwards you will create a blue path.

When you play back you can see both.

enter image description here

What can you do when the tracking stops?

Go back one frame (or where the tracking stopped) Change some settings and re-start the tracking process.

If the tracked object is growing in size or has moved beyond the search area make the search box larger.

(To view the search box enable the Search Marker Display or preass Alt+S)

enter image description here

Change the motion model. Usually changing from Loc to LocRotScale or perspective works well.

enter image description here

For tracked features that change in shape because of the perspective or because they change size, you might want to change the match setting from keyframe (where the tracker uses the original shape as reference to find the matching features) to Previous Frame (where it will try to match the features to those in the previous frame only)

enter image description here

$\endgroup$
1
$\begingroup$

I found the answer. I needed to go to user preferences. System tab and them at the bottom increase the memory cache limit to maximum

$\endgroup$
  • 2
    $\begingroup$ You don't necessarily need to increase the cache limit. Blender will still track but it will be slower. When you cache it only means that blender will load the video frames into RAM, accessing the information faster, when you reach the cache limit, the images will be accesed from the hard drive, making the process a bit slower. I doubt this is the reason the tracking stopped in this case. Tracking stops when blender cannot determine where the tracked element is within the search box area, or when the tracked element is blurred or too close to the edge of the frame, $\endgroup$ – cegaton Mar 8 '18 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.