1
$\begingroup$

I need some help. I can not get an object to rotate around its local axis whit animation-nodes.. It uses the global. Here's how my node setup looks.

enter image description here

$\endgroup$

1 Answer 1

1
$\begingroup$

Record the initials transforms of the object using an ID key, then multiply that transformations by a rotation matrix that hold the rotation data you want.

Node Tree

$\endgroup$
11
  • $\begingroup$ Hi Omar Ahmad Thank you for a quick response. It does not seem to work, almost think it's a bug. The only axis that is local is X. Y and Z use global. Can anyone confirm that it's a bug, or do I have something wrong with my blender? // Patrik $\endgroup$ Commented Mar 8, 2018 at 14:05
  • $\begingroup$ @PatrikRosengren Can you upload the file that have the issue? $\endgroup$
    – Omar Emara
    Commented Mar 8, 2018 at 15:20
  • $\begingroup$ Here's an link to blend file. $\endgroup$ Commented Mar 8, 2018 at 19:27
  • $\begingroup$ @PatrikRosengren You haven't added the initial transforms. In the ID Keys panel in AN panel in the 3D viewport, select the object after rotating it to the desired orientation then press From Current Transforms. Make sure to disable Always auto execution while doing so. Also, in the Compose Matrix Node, you haven't checked Rot, make sure to. $\endgroup$
    – Omar Emara
    Commented Mar 8, 2018 at 20:09
  • $\begingroup$ I'm sorry, does not make it work. I can not find Press From Current Transforms and not Rot checkbox in Compose Matrix Node. $\endgroup$ Commented Mar 9, 2018 at 9:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .