1
$\begingroup$

*NOTE* All of the pictures, unless explicitly stated otherwise, are with mipmaps enabled. Click to get the full-sized images to better see the problem. *NOTE*

It really seems self-explanatory here, but to put it simply, if I enable mipmaps and play the standalone player, the scene's textures have a horrible-looking down-sized effect placed on them. It is noticeable in all resolutions, from 144p to 1080p.

View the full-sized image to better see the problem.

On the other hand, in the embedded player, this doesn't happen at all, no matter what the resolution is: View the full-sized image to better see the problem.

I have tried turning off mipmaps, but if I do that creates a very grainy and noisy image that is totally undesired.

So to put it one last time, I need to get what I see in the viewport into the standalone player.

These are my settings:

enter image description here

Thanks to anyone that tries to help.

$\endgroup$
1
  • 1
    $\begingroup$ Maybe this related post (or the answer by Strapicarus) will help you $\endgroup$
    – AeroLynx
    Mar 10, 2018 at 21:53

1 Answer 1

1
$\begingroup$

When you let the BGE automatically generate the mipmap-textures it will partially result in blurred images. I do not know if there are parameters that can help generate better mipmaps.

To avoid automatic generation you can create your own mipmap textures and provide it in a dds texture file. You can create them with GIMP (DDS plugin). The drawback is the additional work. The advantage is that you do not need to do that for all objects, just the objects where the automatic mipmap generation is not sufficient.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .