2
$\begingroup$

I have problem. I want to use GPU compute rendering, but when I change the userpreference cycles compute device to my gpu (OpenCL), blender cannot do rendering and shows that failed loading render kernel. enter image description here

This is the spec of my laptop GPU (not sure what is called):

farestp@farestp-X555QG:~$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: AMD CARRIZO (DRM 3.18.0 / 4.13.0-36-generic, LLVM 6.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.1.0-devel
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 18.1.0-devel
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.0-devel
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

enter image description here I use Ubuntu 17.10. Asus-x555QG. Use oibaf's driver.

This is the appearance from console:

farestp@farestp-X555QG:~$ CYCLES_OPENCL_SPLIT_KERNEL_TEST=1 /home/farestp/Downloads/blender-2.79-b5b5260464f-linux-glibc219-x86_64/blender
Read prefs: /home/farestp/.config/blender/2.79/config/userpref.blend
found bundled python: /home/farestp/Downloads/blender-2.79-b5b5260464f-linux-glibc219-x86_64/2.79/python
trying to save userpref at /home/farestp/.config/blender/2.79/config/userpref.blend ok
trying to save userpref at /home/farestp/.config/blender/2.79/config/userpref.blend ok
trying to save userpref at /home/farestp/.config/blender/2.79/config/userpref.blend ok
Device init success
Compiling OpenCL program base
1 warning and 1 error generated.
OpenCL build failed with error CL_BUILD_PROGRAM_FAILURE, errors in console.
OpenCL program base build output: Build option isn't yet supported by clang: -cl-no-signed-zeros

Is this bug? or I am missing something when install OpenCL? I am newbie with linux... :)

Thank you~

$\endgroup$
  • $\begingroup$ Remove pocl package and don't forget to install package from synaptic related to opencl fix this problem... But I encounter another problem... Maybe another people could solve more clear $\endgroup$ – Fares TP Mar 7 '18 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.