1
$\begingroup$

I have this problem, when I try to enable denoising when rendering with my GPU only I get a completely black rendering. When I render with CPU+GPU I get black tiles. I´m running Blender on an iMac with a Radeon Pro 560 4GB GPU, and Intel Core i5 3.4 Ghz.

that´s a simple test i did with a mesh from manuelbastionilab 1.6

anyone experiencing similar problems ?

$\endgroup$
  • 1
    $\begingroup$ does it work correctly if only rendering with the cpu? I'm guessing amd driver/incompatibility. $\endgroup$ – David Mar 6 '18 at 14:08
0
$\begingroup$

I did a little testing on the new egpu I have for my imac and there is definitely an incompatibility on my system between the board and the denoiser.

The incompatibility seems to make everything black with the Glossy Direct turned on.

With Glossy Direct turned off, everything is wicked contrasty after denoising.

With the glossy indirect turned off, everything is extremely dark after Denoising.

Playing with the different denoising levels doesn't change any of that.

I am running an AMD Radeon R9 in an Akitio enclosure, with a 2015 imac. Renders are faster but I definitely wish I could run the denoise to cut down on samples.

Hopefully, the incompatibility will get fixed in the next version.

$\endgroup$
0
$\begingroup$

I think denoiser behaves quite different on different video cards. I just added eGPU to my setup with Vega 56 on Mac and denoiser works and sliders affects the final image while with the build in Radeon R9 M370X it did not worked at all.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.