0
$\begingroup$

Yesterday i was able to open the blender and use it normally; i updated to win10 3 days ago and was deleting and changing some stuffs in order to have a less slow pc and fix other problems with the double screen and other things. The thing is that now after finishing the "cleansing" i found that i can't open blender because of this:

enter image description here

But... before this message, i was having another issue while opening blender that was the one of the reason behind of this "cleansing". I had that annoying "LoadLibrary failed with error 87: The parameter is incorrect". After some research, i found that a way to solve it was by renaming the OpenGL driver "atig6pxx.dll" to "atig6pxx.dll.bak", and so i did that change and it worked, no more loadlibrary error, but... when i opened the Blender i got the message of not working/updated drivers, so, i went to the Driver Booster and updated 2 drivers, indeed, there were 2 drivers not updated after all this "cleansing"; i restarted the pc and after that... i opened the Blender and... BAM! another wild driver error message appears! I used Driver Booster to update the drivers, but it wasn't effective! (the drivers were already updated), so i decided to watch closely what was written in the cmd black screen, and found this damn message "Warning! Legacy WGL is unable to select between different OpenGL versions" and i remembered the renaming process i did to solve the "loadlibrary failed error", and i asked myself "maybe that could be the problem", so, i went to the same folder, find that file and rename it back to it's original name, but guess what? it had its original name again! and i was like "okay, no problem... maybe that's the problem" so i decided to do the same like before, renaming it adding ".bak" and the end, but now this time i couldn't complete the task because i needed permission of "SYSTEM", and i was like, "oh god, why". So... that's it, That's the story. Before this cleansing, i was able to open the Blender normally, but after that, i had all these issues i aforementioned in the story.

The Blender version i have is 2.79 (just in case).

Any suggestion on how i could fix this? ¡¡¡I HAVEN'T USED BLENDER IN 3 DAYS AT THIS POINT!1!1!

$\endgroup$
3
$\begingroup$

This is not a Blender question but I'll try to help you anyway.

Uninstall any display drivers you installed previously using DDU. Then just run a Windows update, that should load the most stable driver for you automatically. If that still doesn't work, go to amd.com, nvidia.com, or intel.com and find your driver from the Download/Support/Driver page.

A warning for the future, randomly renaming dlls is not a solution, it's a hack at best and is dangerous unless you understand what it's doing. In this case, you basically removed the OpenGL driver.

$\endgroup$
  • $\begingroup$ Thank you so much! it worked fine. You're the man, now i'll be able to work in Blender again! :D $\endgroup$ – J. J. Mar 5 '18 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.