2
$\begingroup$

I just got myself a new graphics card that is able to handle workflow. I still got really bad playback performance of the 3D view combined with animation by armature.

I usually get displayed 0.83 FPS though my graphics card is only at 11% usage.
I always thought that my old one was the reason for horribly bad playback but the problem still is consistent and I have no idea why.
My CPU is at 22% usage by Blender and also RAM is there as much Blender would need, it does not increase in performance/take the ressources.

I know this question is very much technical, but I need help finding out why it does not work so smoothly as I had expected. The new module is working without any problems with graphics intense games, and other applications.
What could be the reason that it still does not work fine though I barely go any objects included in the current file and even bounding box vision with the armature alone makes Blender work so horribly slow?
And if this really does not belong here, please tell me where to ask for help at least...

$\endgroup$
  • $\begingroup$ I’m not an incredibly technical person, but what kind of graphics card do you have? Your computer sounds like it has good specs. Are there any other softwares that run slow with your graphics card other than graphic intense games? It might just be that blender is not optimized for your GPU. Have you tried using solely the CPU (you can change it in the render settings under device)? In user preferences under system you can check if your Graphics card is compatible. It is if there is an option labeled CUDA. Hope that helps :). $\endgroup$ – Raiyan Rizwan Mar 3 '18 at 22:10
  • $\begingroup$ Mine is called NVIDIA GTX 1060 6GB. I just got it installed yesterday so I am not sure if there is. I know from other people that it should work properly... I found the option CUDA and enabled it. If it improves, I will tell you. Thanks for your help. $\endgroup$ – xDonnervogelx Mar 3 '18 at 22:14
  • $\begingroup$ I have just tested; I have 1.45 FPS now... a bit better but I have no idea why it works so slowly... $\endgroup$ – xDonnervogelx Mar 3 '18 at 22:15
  • $\begingroup$ Any time. That is quite odd. I have a Nividia GeForce 940m and yours is quite a ways better than mine but I am able to get 30 or so FPS. It must have something to do with your GPU settings rather than the card itself. You do have it set to GPU under device in render settings right? $\endgroup$ – Raiyan Rizwan Mar 3 '18 at 22:25
  • $\begingroup$ Could you tell me where to find that option? I cannot see it after my tries to fix it. $\endgroup$ – xDonnervogelx Mar 3 '18 at 22:32
2
$\begingroup$

Playback in the viewport is completely dependent on the CPU, unless you're in rendered mode. The CPU is used to calculate stuff like where your meshes are and how the armatures make them move.

The graphics card is only used for rendering related tasks like calculating light bounces, shading, and colors. If you're in the solid mode of the viewport your graphics card only has to figure out what shade of grey the faces on your mesh are, which is a trivial task even for very weak GPUs.

Going back to CPUs, it's important to know that Blender's viewport is single-threaded. This means that if you have a quad-core CPU, the viewport can only use one of the four cores. If you look at the usage for individual cores rather than overall usage, you'll probably see one is maxed out and the rest are idle (in Windows task manager, right-click the CPU graph then select logical cores).

Here are a few ways that you might be able to increase your single-core performance besides upgrading your CPU:

1) Turn off Hyperthreading if your CPU has it. Hyperthreading is where your computer sees each physical CPU core as two (or more, but usually two) cores. This provides better performance for multi-threaded tasks like video editing, but effectively halves performance for single-threaded stuff like Blender's viewport. The option to turn it off is probably somewhere in your BIOS, which is unique to your computer so probably Google it. Some laptops (including mine >:( ) don't have the option to turn it off, so that stinks.

2) Clean out all the dust in your computer. When your computer gets too hot, it will automatically decrease performance so it doesn't overheat. This is called thermal throttling. If you clean out the dust with some compressed air, the heat sinks and fan will get better airflow and be able to keep your computer cool at higher speeds. This method is mostly aimed at laptops, since desktops tend to have much better cooling systems and don't really suffer from this.

3) Replace the thermal compound between your CPU and heatsink. Same idea as the last one, if your CPU can conduct heat more efficiently onto the heatsink, it'll throttle less and run faster. Stock thermal compounds tend to be pretty bad and can wear out. I'd suggest Arctic Silver 5.

4) Use Linux!! Linux handles the CPU much more efficiently than Windows, and you can get a pretty good performance increase just from switching over. For awhile I thought this was just Linux fanboys telling tall tales, but I recently switched my mega project over to Linux for RAM related reasons and I really felt the performance increase.

5) (edited in, somehow I forgot this on the original post) Overclock if your PC supports it (but use caution).

Hope this helps :)

| improve this answer | |
$\endgroup$
  • $\begingroup$ haha to 1), I do not have BIOS. My start system is called UEFI. Kind of an upgrade that came with my motherboard. 2) Could be maybe also the high heat in the room currently (we got a heater that is too large for the tiny room but without it I would catch a cold easily). I though got like... 5 to 6 fans in my computer if I count in the ones of my graphics card. 3) ah this is what someone suggested me because I got the cooler from Intel and that person said that intel coolers are worth sh.t so maybe it could be that one 4) oh I had Ubuntu a few years ago... wasnt easy to handle...+streamin? $\endgroup$ – xDonnervogelx Mar 3 '18 at 23:38
  • $\begingroup$ Thank you for the comment though I will think about each option. $\endgroup$ – xDonnervogelx Mar 3 '18 at 23:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.