0
$\begingroup$

I found a great tutorial on rigging a horse (https://www.youtube.com/watch?v=gR2OV9r76_w), but there's a problem with mine.

When I try to move the object's leg, its foot gets stuck on the ground. I'm not sure why this is happening, since I tried to follow the tutorial from start to finish. Everything else is working perfectly.

Here are my animal's legs:

This is what happens when I move the object (Notice the foot 'sticking' to the ground): enter image description here

Does anyone know a way to solve this or why it's happening?

$\endgroup$
1
$\begingroup$

The mesh is wrongly skinned to the Armature. Vertices of the bottom parts of the legs are probably influenced by root bone. To avoid that you should turn off Deform on the root bone (you should also turn it off on the IK target bones), clear bone groups, that was created by Parenting with automatic weights,delete Armature modifier and clear parent from the mesh. Then repeat parenting with automatic weights and you'll be good to go. Below you'll find image with the placement of Deform option in bone properties.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you, but I forgot to mention I already did that. I noticed another problem, not only does it stick to the ground, but the other side slightly mirrors the movement for some reason as well (even though I've already applied mirror modifier to the model one day ago). I just can't figure out where I messed it up. $\endgroup$ – frostpad Mar 3 '18 at 21:21
  • $\begingroup$ You're welcome. If it didn't fix the problem, then I don't know either what you messed up. Upload your file using blend-exchange.giantcowfilms.com and we'll check. $\endgroup$ – Mzidare Mar 3 '18 at 21:49
  • $\begingroup$ I uploaded the file. A bit of difference in weight painting made it look a bit better, but movements still look awkward and sticky. $\endgroup$ – frostpad Mar 3 '18 at 23:07
  • $\begingroup$ Looks like you didn't do, what I advised in the answer, cause after doing exactly this on your file, problem got solved. Root bone, of which I'm talking about in the answer is called Bone.012 in your file. $\endgroup$ – Mzidare Mar 4 '18 at 13:23
  • $\begingroup$ Although in your case, you need to make one more step, before parenting with automatic weights. You must go into edit mode of your horse mesh and press Ctrl + N to flip normals. Now they are turned inside (mesh looks dark in the viewport) and it confuses automatic weighting. $\endgroup$ – Mzidare Mar 4 '18 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.