I have a mesh that is created based on a cylinder that I cut using a Boolean modifier 'difference', against an stl file representing a natural object. The stl file of this natural object consists of triangles. I cannot get a version of this file with quads instead of triangles. The result of this is that the mesh I want to modify, also consists of triangles.

See photo, I want to bevel, or round the edges on the bottom of the mesh, however, I want to know if there is a way to do this that is easier than manually selecting the edge loop on the bottom. Since the mesh consists of triangles, 'select edge loop' doesn't work.

enter image description here

  • $\begingroup$ Select loop of outer faces, deselect loop of top edges? Or using Sharp Edges from the Select menu.. If just dealing with selection tools it has a lot of choices $\endgroup$
    – Mr Zak
    Commented Mar 2, 2018 at 12:56

2 Answers 2


I have similar problems and I really miss nondestructive booleans, but your's is kinda easy to fix.

Let's say you have this ugly topology here:

only a mother could love it

If you still have the original scanned mesh in place, you don't need to do this: Select all the tris, duplicate them and separate them into their own object. Then extrude and scale both rims to have more surface area.

mean green pancake from outer space

Go back to your original mesh. Make a cut with the knife tool and get rid of the bad topology.

alex knew what to do

Select both edgelines and bridge the edgeloops. Now is a good time to assign the top verts to a vertex group. Depending on your mesh, the 'Limit' value of the modifier might suffice and a vertex group will not be necessary.

strength in numbers

Give your mesh a shrinkwrap modifier set to project, let it only affect your vertex group and play with the settings until you get this trainwreck.

teeth, teeth, horrible teeth

Turns out the Shrinkwrap doesn't like to project on edgelines that fit perfectly. Move it a tiny bit, any amount will do.

bit picky

And this is the result. A clean topology, ready to be bevelled.

Finally beauty

Sometimes a Shrinkwrap is much better than a Boolean Modifier since it doesn't destroy the topology.

These settings worked for me:

shrinkwrap settings

Wait, did I mention that there's another way of doing this? No?

Well, there's another way of doing this.

Ugly mesh again. New one since I forgot to copy the first one.


Select all the top verts and hit X 'only Edges and Faces'. That kills all connecting edges up there. It isolates all of the rogue topology from the edges that rise from the bottom of the mesh.

wittle boidies

Hover over the base, hit L to select the important part of the mesh and hide it with H


Select the rest of the verts and utterly delete them. Reveal your mesh with ALTH.


Select the base and hide it again. Switch to top view.

edge wars

Select all the inner verts, turn them into an ngon with F and delete the ngon with F 'only faces'.

the edgeloop strikes back

Do the same for the outer verts, select both rings and bridge them with SPACE 'Bridge Edge Loops'.


Select the whole mesh, hit F to fill all the holes and CTRL-N to recalculate normals.


That one helped: Fastest way to turn a ring of unconnected vertices into an edgeloop?

  • $\begingroup$ Another beauty. Is the crumpled plane mesh you project onto made from the original mesh? $\endgroup$
    – batFINGER
    Commented Mar 2, 2018 at 20:29
  • $\begingroup$ @batFINGER By the time I got this far I hade already deleted the mangled sphere. So I duplicated the upper part of the target mesh and seParated it. It's of course faster if you still have it. $\endgroup$ Commented Mar 2, 2018 at 20:44

This might not help, but if you want to round the mesh try using the subsurf modifier. When you do this, you’ll probably get a weird shape with subsurf rounding the top flat section too (like subsurf on a normal cylinder would make a balloon). To fix this go to edit mode and simply press ctrl+r to make a loop cut at the center of mesh (purple ring). Now move the loop cut all the way up till the curve is flat again. If you accidentally place it wrong just select it and hit “g” twice to move it. You can do this for the bottom too if you don’t like the curve. Then, you’ll notice a weird rounded edge at the top. Just select the face and press “I” to inset it. I hope that helps some :).


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .