0
$\begingroup$

I setup a simple animation nodes node tree to experiment with the animation of a shape key and a material node of an object (cube). This is the node setup: Although, as stated in the comments below, this does not necessarily seem to be an animation node related issue ..

Node Tree Setup

I added the sound sample in the video editor and then matched the animation end frame (140) to the length of the sound file strip. When I play the sound by pressing play in the timeline (still video editor) the sound exactly matches the length from start frame to end frame.

But when I change back to node editor and press play in the timeline the sound has already finished on a much earlier frame (like 87) but the animation will go on until frame 140 without sound.

I tried to tweak the all over fps value but with no success.. (and without knowing WHY exactly)

Any ideas what I miss(do wrong here? Thx ..

$\endgroup$
  • 1
    $\begingroup$ It seems to be working fine for me. This doesn't seem to be an Animation Nodes issue, because, as you said, the animation is working as expected and the sound is the one that doesn't work. Consider turning on AV-Sync in the frame editor and try again. $\endgroup$ – Omar Emara Feb 28 '18 at 15:22
  • $\begingroup$ Ok, it worked directly after I turned on the AV-Sync option as you suggested. Can you explain why the sound matched the start and end frame length in the video editor but not in the default view? Isn't it the same window/function? And.. to spare future users confusion I will delete the Animation Node part from my question title, thanks for figuring out .. $\endgroup$ – ho.s Feb 28 '18 at 15:37
  • $\begingroup$ I added an answer with more details. It would be a good idea to remove the Animation Nodes tag as well. Also there is no need for the first line of your edit, the comments are visible to everyone and the edit log as well, so you should probably remove it. $\endgroup$ – Omar Emara Feb 28 '18 at 15:48
2
$\begingroup$

Some times when dealing with Audio files in blender, the viewport becomes slow due to some factors, however, the audio files is maintaining its speed and rate, so they go out of sync.

A possible solution is to enable AV-Sync, which dropes some frames in order to keep up with the sound file. Another solution might be to reduce the factors that are slowing down your experience.

AV Sync

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.