0
$\begingroup$

enter image description here

So I made a ragdoll horse in the Game engine using an armature and some hitboxes. I connected these hitboxes with Rigid Body Joints. Now I want to use this rig for animation. However, I animate with Cycles. I know that the Rigid Body Joint does not work in Cycles, and the Rigid Body Constraint set on Hinge in the physics tab doesn't do the same thing- it just stays rigid and doesn't swivel. Is there any way to get the same effect that I get with Rigid Body Joint, but in Cycles?

$\endgroup$
6
  • $\begingroup$ I don’t understand... cycles does support rigid body constraints and they should work fine - although you may need to recreate them while in Cycles mode rather than trying to use those that were created in the game engine as they aren’t compatible. $\endgroup$ Commented Feb 28, 2018 at 12:46
  • $\begingroup$ I already tried that, however, when I add a Rigid Body Constraint to two hitboxes, they fall through each other and don't collide. $\endgroup$
    – Fayabella
    Commented Mar 2, 2018 at 1:22
  • $\begingroup$ What should I do? I've tried everything I can think of, but they just won't collide. $\endgroup$
    – Fayabella
    Commented Mar 27, 2018 at 18:01
  • $\begingroup$ Rigid Body Constraints disable collisions with their neighbours by default - you have to switch a checkbox in the physics properties to enable it. Failing that, can you post your Blend file to blend-exchange.giantcowfilms.com and edit your question to paste the link. $\endgroup$ Commented Mar 27, 2018 at 18:21
  • $\begingroup$ Oh! Duh. I should have seen that. Thank you! $\endgroup$
    – Fayabella
    Commented Mar 28, 2018 at 19:06

1 Answer 1

0
$\begingroup$

The game engine rigid body joints do not work outside the game engine. For similar behaviour in Cycles you should use Rigid Body Constraints - these can be created by selecting two or more rigid bodies and clicking Connect in the Physics Toolbox panel (T). When a rigid body constraint is first added it defaults to ‘Disable Collision’ - to enable collision between linked objects you should untick the checkbox in the Rigid Body Constraint physics properties.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .