I'm looking into the Blender Video Sequence Editor to create animations out of existing sequences of images. The image sequences are generated with POV-ray. I've downloaded Blender 2.79, I run W7 64-bit.

I did a test and I noticed that in the rendered video the background color was quite different from the source. For the source images the background color is White: RGB(255,255,255). In the rendered video the background color is a bluish grey. I took a screenshot, copypasted it in GIMP, and according to GIMP the color is RGB(234,234,245).

What can be the cause of that change of color, and is there a way to prevent that from happening?

Example of source image, background color 255,255,255

Example of rendered frame, background color 234,234,245

For rendering settings I followed as much as possible the recommendations in the VSE tutorial series by Mikeycal Meyers.

Mikeycal Meyers recommends for the 'encoding': Xvid, and the dropdown menu does show that option:

The Xvid setting in the dropdown menu

Note that after clicking on the option 'Xvid' the text displayed in the 'encoding' field remains 'presets', so it is unknown whether or not Blender has accepted the 'Xvid' selection.

VSE display of the rendering settings used

I have zero knowledge of which 'container' setting and which 'codec' setting will suit my purposes. I chose 'mpeg-4' pretty much at random.

The video that I have in mind will be a combination of some 2D scenes (white background), some 3D scenes (white background), and a couple of shots filmed with some form of video camera.

I assume that all the shots that are to be combined into a video must be rendered with the same codec. Since some of the shots will be camera shots I assume the codec that is to be used needs to be a general purpose codec rather than some special purpose codec.

What can be the cause of the change of the background color? Is it perhaps something that the Blender VSE has done, or is it perhaps an artifact of the codec that was used (or perhaps a combination of both)?

Is it perhaps the case that the codec that was used is not designed to preserve color? I did expect the type of barely noticible color blurring that you get with jpeg compression, but the sweeping change of background color comes as a total surprise to me.

Since multiple difference image sequences will be incorporated in the final video it is essential that the background color is absolutely consistent, otherwise there will be a jarring change of background color going from scene to scene.

Let me try and upload a screenshot of the full window.
(I have a dual display setup, with both displays in portrait orientation)
For this first test this is the current screen layout.
Screenshot of full window

I gave Blender a good night's sleep, and after restarting the computer and restarting Blender I noticed something had returned that was gone the previous session: a video editor preview. (See the screenshot of the full Blender window: only a checkerboard pattern, but no preview.)
video editor preview

When I drag the vertical green line in the video sequence editor the preview displays the corresponding frame from the source image sequence.

  • $\begingroup$ Does it happen when you render a still image and check it in the image editor or does the color change only come after saving the image? $\endgroup$ Commented Feb 25, 2018 at 0:06
  • $\begingroup$ @Haunt_House Please keep in mind: I'm absolutely new to the Blender VSE, so I don't know what UI element is referred to as the 'image editor'. Note that following the recommentations by Mikeycal Meyers I have changed the 'screen layout' from '3D view' to 'video editing'. I'm guessing the 'video editing' layout doesn't include the 'image editor' UI element. Please note I am exclusively exploring the Video Sequence Editor. The image sequences I want to encode into video have been generated by POV-ray. $\endgroup$
    – Cleonis
    Commented Feb 25, 2018 at 0:46
  • $\begingroup$ Keep in mind that I'm using this monster since 2001, so some of your blind spots might be in danger ( : If you press F12, an image appears.. there you can measure pixels as well. If the tint is in there, it has nothing to do with the encoding. Lets exclude error sources one by one $\endgroup$ Commented Feb 25, 2018 at 0:49
  • $\begingroup$ Related: Compression & Color change and Video format/encoder settings that don't destroy image? $\endgroup$
    – user1853
    Commented Feb 25, 2018 at 1:32
  • $\begingroup$ @Haunt_House I have edited my question to include a screenshot of the full Blender window as it is currently configured. Here, pressing F12 does not have the effect of making an image appear. The only effect of pressing F12 (in this configuration): the text in the far upper right flickers for a fraction of a second. That is, the text 'blender 2.79' and 'verts 8', etc. flickers for a fraction of a second. I'm guessing those 8 verts and 6 faces refer to the default shape in the '3D view'. $\endgroup$
    – Cleonis
    Commented Feb 25, 2018 at 1:34

1 Answer 1


It now appears that I was wrong in suspecting this was something going wrong in the stage of rendering from image sequence to video. That is, it doesn't seem to be a Blender problem.

Timeline of my efforts:
I had viewed the rendered video with Windows Media Player, with Firefox, and with VLC player, same background color in each. With these three players giving the same result the error seemed to be in the video file itself.

For comparison I downloaded and installed Openshot video editor. Rendered a video (displayed with the same wrong background in the three players), then re-imported that video in Openshot. Then in the Openshot preview display the background color was correct: White.

Next I transfered a Blender rendered video to another computer, played it with VLC player, took a screnshot of a still and checked the background color, came back as RGB(255,255,254).

All of this indicates that the root of the problem is some misconfiguration of my graphics card. Somehow display of the video goes wrong for each of the players that I used : Windows Media Player, Firefox, and VLC player.

While I don't know how to address the misconfiguration problem, it's pretty clear now that it never was a Blender problem.

  • 1
    $\begingroup$ It is likely a decoding problem. The values you cited are close enough to the broadcast scaled versions to suggest that the decoding is broken. Some further information here: blender.stackexchange.com/questions/12262/… $\endgroup$
    – troy_s
    Commented Feb 26, 2018 at 1:00

Not the answer you're looking for? Browse other questions tagged .