2
$\begingroup$

I'm new to Blender and trying to make an image. I'm almost there but something is confusing me. Right now, I have this blue rectangle that I want in the same plane as the other objects. For example, here it is from a couple angles:

enter image description here enter image description here

and rendered:

enter image description here

Now, I want that blue rectangle to be mostly transparent, so you can see the rest of the shape that it coincides with very clearly. So, I went to the materials tab with that object selected, clicked the transparency box, and messed with the alpha parameter, making it very low:

enter image description here

Now, when I render it, it does look different...but isn't actually transparent:

enter image description here

what am I missing here? How can I achieve this?

$\endgroup$
  • $\begingroup$ Those transparency settings are for viewport only, not materials or rendering. How are you rendering this? $\endgroup$ – Duarte Farrajota Ramos Feb 22 '18 at 19:40
  • $\begingroup$ @DuarteFarrajotaRamos just hitting F12, which does Blender Render. $\endgroup$ – MasterZibZob Feb 23 '18 at 3:37
2
$\begingroup$

You have set your transparency to Mask. To quote the Blender Manual:

This option simply masks the Background. It uses the alpha channel to mix the color of each pixel on the active object plane with the color of the corresponding background pixel, according to the alpha channel of the pixel. Thus for alpha = 1, the object color is seen – the object is completely opaque; but if alpha = 0, only the background is seen – the object is transparent (but note that any other object behind the active object disappears).

Essentially, any object behind a 'Mask' object will not be visible. Instead, set the transparency type to Z Transparency or Raytrace:

enter image description here

$\endgroup$
  • $\begingroup$ Thanks so much, that works! I just have one detail I want to change still (and I'd like to avoid making another thread); even when I set alpha = 0.02, it's very transparent but it's making the object behind it very dark, nearly black in the render. It seems like the object (the squiggle) should appear nearly as it does in the section not covered by the transparent block...what's the deal? Thanks! $\endgroup$ – MasterZibZob Feb 23 '18 at 3:14
  • $\begingroup$ I do suggest asking a new, separate question, however, I think the object behind needs 'Receive transparent shadows' enabled in the 'Shadow' panel. As for this answer, if you feel it has answered your question you can 'accept' it. See: meta.stackexchange.com/questions/5234/… $\endgroup$ – Ray Mairlot Feb 23 '18 at 4:05
0
$\begingroup$

In the material panel, Set transparency mode from Mask to Z Transparency. This will allow objects behind it to show through.

Mask is used to blend the material with the sky color, if I remember correctly.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.