0
$\begingroup$

I successfully select group of edges use Alt+RightMouseButton, but when I need highlight one more group of edges and use Shift+Alt+RightMouseButton, the old selection is deleted and the new selection is not highlighted (In theory, it action should save old selection and add new). How i can fix that?

$\endgroup$
  • 1
    $\begingroup$ windows, linux or mac? Are you using the blender default keyset? Any programs that could be messing with the key input? $\endgroup$ – David Feb 21 '18 at 0:18
  • $\begingroup$ David, linux, yes, default keyset. No third-party programm, but maybe system shortcut Alt+Shift(change keyboard language) can interrupt $\endgroup$ – Evgeniy Feb 21 '18 at 0:23
  • 2
    $\begingroup$ that OS change keyboard language shortcut sounds very likely to be the issue. Try changing that and see if blender works. $\endgroup$ – David Feb 21 '18 at 0:24
  • $\begingroup$ David, you were right, i disabled this system shortcut and blender work normal. But it is very usable shortcut(i use it every time), maybe there is some way to save it and normal blender works? $\endgroup$ – Evgeniy Feb 21 '18 at 0:32
  • $\begingroup$ Possible duplicate of: blender.stackexchange.com/questions/60961/… $\endgroup$ – cegaton Feb 21 '18 at 0:45
1
$\begingroup$

Assuming it is not an issue with your keyboards shift key or an external program interfering with its function. (Network Mouse Applications usually interfere)

Goto User Preferences -> Input -> 3D View -> 3D View (Global) -> Activate Select Look for the Shift+Alt+Select Mouse Entry. It should have Toggle Selection and Enumerate checked. If it does not exist you have to create it or reset your whole keybindings.

$\endgroup$
  • $\begingroup$ Preferences set uped how you describe $\endgroup$ – Evgeniy Feb 21 '18 at 0:27
  • $\begingroup$ Than its most likley an external issue. Like a network mouse application, or a shortcut of your desktop. Try googling shift+alt shortcut in combination with your desktop. be it windows or kde or gnome, mate, osx, etc. $\endgroup$ – Gerald Degeneve Feb 21 '18 at 0:31
1
$\begingroup$

I replaced desktop shortcut Alt + Shift to caps lock and Blender hot key worked fine

$\endgroup$
-1
$\begingroup$

User Preferences --> Emulate 3 ButtonMouse --> Uncheck this Option

$\endgroup$

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 2
    $\begingroup$ Could you elaborate on why do you think this solves the question? $\endgroup$ – Mr Zak Nov 15 '18 at 21:15
  • $\begingroup$ I do not really know why this happens, but when i switch on - off the three button emulation, from the user preference menu, that affects the shift+alt+left click command. probably due to disabling tha alt key function. $\endgroup$ – appa Nov 15 '18 at 23:36
  • $\begingroup$ hope that is helpful :) $\endgroup$ – appa Nov 15 '18 at 23:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.