1
$\begingroup$

First time here at Blender exchange.

So this is how I marked the seams in this test model but when I go to UV unwrap it this is what I get:

enter image description here

Its like regardless of what I do this part here never gets separated into its own island and I dont know why:

enter image description here

I'm obviously not an expert but I've UV unwrapped other models in the past and never had this problem, I've tried different things but so far I haven't been able to pin point the problem, so I'm sure I'm just doing something incredibly silly.

Any help? Thank you!

EDIT: Okay so I just found that I had a couple of vertices really close together and they seemed like they were one so there was some edges that werent marked as seam! But, now that I've fixed this when I UV unwrap it even though it's a lot better I still have this:

Why is it stretching like that there?

EDIT 2:

EDIT 3: What I'm really trying to understand here is that in this example: enter image description here Why are those vertices appearing in the wrong position, and why if I manually try to move them in the correct position the other vertices in the other island get moved too even though they are in a different island?

$\endgroup$
  • 1
    $\begingroup$ Have you hit ctrl alt shift m in vertex select mode to check for any renegade geometry? It seems like some edge is still connected. $\endgroup$ – Haunt_House Feb 20 '18 at 21:51
  • $\begingroup$ Do you mean the "Select Non Manifold" thing? I've never used it but fiddling around with it for a bit didnt show anything weird, also I just recreated the model to make sure I didnt create any hidden geometry by accident or anything and I'm having the same problem $\endgroup$ – Giantswing Feb 20 '18 at 21:59
  • 1
    $\begingroup$ Welcome... Adding your .blend to your original post using blend-exchange.giantcowfilms.com would help. $\endgroup$ – Dontwalk Feb 20 '18 at 22:23
  • $\begingroup$ Hey sure! I just didn't knew how to do it, I just uploaded the file and posted in the bottom of the original question, thanks for your time! I'm just trying to really understand how UV's work on a more internal level $\endgroup$ – Giantswing Feb 20 '18 at 22:27
  • 2
    $\begingroup$ Likely Ngons are the reason. They can provide some stretching even when it's flat surface $\endgroup$ – Mr Zak Feb 20 '18 at 22:42
1
$\begingroup$

The problem lies in the ngons so you have two options here.

a: Select each faces you want to have an island of and unwrap/smart unwrap it. This won't attach both side as one island but it will give you consistent uv maps for both sides. The UV islands will be overlapping so you want to pack the island. packed

b: get rid of the ngons: knife cut it looks a bit botched because I knife cut the faces in a hurry.

edit: You might want to change the method and check/uncheck fill holes to your liking

$\endgroup$
0
$\begingroup$

I'd try this

Edit mode > select all
Mesh > UV unwrap > Smart UV project
Island margin: 0.03

Smart UV

$\endgroup$
  • 2
    $\begingroup$ Thanks, I know about Smart UV Project, I just dont think it's a good option as soon as you start unwrapping a complex model, it creates way to many islands and you basically have no control on how the model unwraps, it may be a viable option for something quick and dirty, but I'm trying to understand how to properly unwrap a model $\endgroup$ – Giantswing Feb 20 '18 at 22:15
  • 1
    $\begingroup$ Do what'cha wanna, but it saves me time from fiddling with UV layouts, so I prefer it. $\endgroup$ – Doyousketch2 Feb 20 '18 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.