Is there away to turn this setting completely off? Sometimes after I'm done exporting my work, I have to go back and re-export the files again because I forget to click Selection Only.

enter image description here


That's actually pretty possible and only becomes a problem when you install a new Blender version.

In your installation directory, you have the path: scripts\addons\io_mesh_stl\

In that folder, there should be the .py files concerning stl import/export.


is the one to open and mutilate.

In line 166, I find:

use_selection = BoolProperty(
        name="Selection Only",
        description="Export selected objects only",

The only thing you need to do is to turn 'False' into 'True' and you should have your checkbox filled by default. The same way you can adjust any default setting. Endless possibilities.

| improve this answer | |
  • $\begingroup$ That worked :) you are the best. $\endgroup$ – Daniel Rahmani Feb 21 '18 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.