I'm trying to do a simple cup, I have reduced the materials to an absolute minimum of nodes, so the issue probably isn't in the material. The rendered view in the viewport looks like this: preview

but the final render like this: final render

Tried to fix normals, remove doubles, looked for duplicate objects, but nothing seems to work.

  • 2
    $\begingroup$ That looks like z-fighting to me. If it is only in the final render, have a look at your modifiers, something is duplicating your mesh. $\endgroup$ – sambler Feb 19 '18 at 19:24
  • 1
    $\begingroup$ Duplicated geometry indeed. Look in the outliner window for any objects that are disabled for viewing in the viewport (eye icon) but are enabled for rendering (camera Icon). $\endgroup$ – user1853 Feb 19 '18 at 19:30
  • $\begingroup$ @sambler Thank you, I don't know why but I had a boolean modifier on the handle. $\endgroup$ – LinieKiste Feb 19 '18 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.