1
$\begingroup$

Apologies, I'm sure this question has been answered before, but so far I have not found a solution that works in my situation.

I have a path that my camera follows and a second path that my camera focus object follows. Neither path uses the Animate Path button nor have I parented either to their path with 'CTRL-P'. Instead I keyframed the offset of the camera and the focus object to gradually accelerate/decelerate and rapidly accelerate/decelerate at different locations along their respective paths.

When I tried to combine keyframing the offsets together with Animate Path/parenting, the camera's location would leave the path, etc.

According to the Blender Manual, the Clamp To constraint does not allow for object rotation, so using that to keep my camera on it's path is not an option.

Now I want to roll the camera 90 degrees along a specific section of it's path, while still tracking my camera focus object. When I select the camera and press 'R' or 'RR' and then 'Y' or 'YY' (or X or Z) the camera's location rotates off the path in a huge circle. When I select the camera focus object and try the same hotkeys, the camera does not rotate at all. If I use Numpad-0 to see the camera's perspective while rotating, it makes no difference.

Camera Follow Path constraints:
Fixed Position: Checked
Follow Curve: Unchecked
Curve Radius: Unchecked
Forward: -Z
Up: Y

Camera Track To constraints:
To: Z
Up: Y
Target Z: Checked
Space: World Space <-> World Space

Weather Target Z is checked or unchecked and Space is World Space or Local space makes absolutely no difference. The results are the same.

I would greatly appreciate any help. Thank you.

$\endgroup$
1
$\begingroup$

Instead of having the camera track anything, let an empty do the job. Parent the tracker empty to the path and let it track the focus empty, then parent the camera to the tracker empty. That way you can rotate the camera freely. All the path motion is done by lesser beings.

In the picture I have moved the camera a little away from the empty to show the relationship line. That's just for clarity purposes. Usually you'd keep it smack on the tracker empty.

Another benefit: since the camera is in local space due to parenting it, you can lock its X and Z rotation.

enter image description here

The empties do all the pointing and moving, so rolling the camera around its local Y axis is all that's left to do.

enter image description here

Inbetween objects simplify a lot of complex hierarchies.

$\endgroup$
  • $\begingroup$ Thanks for your comment @Haunt_House. Could you clarify a little please? Do you mean have the empty follow my camera path and parent the camera to the empty or do I still need separate paths for both to follow? Because sometimes my camera focus empty is stationary while my camera is moving and other times they are both moving closer together or farther apart, relative to the scene. Thanks again. $\endgroup$ – yetanotherusername Feb 18 '18 at 20:58
  • $\begingroup$ I hopefully clarified it a little. You're it ( : $\endgroup$ – Haunt_House Feb 19 '18 at 11:39
  • $\begingroup$ thanks very much. That is very helpful. I tried doing this myself but it still doesn't work because my project file is bugged or something. Thanks again for the response. $\endgroup$ – yetanotherusername Feb 20 '18 at 8:37
0
$\begingroup$

I figured out the actual problem is my blender project file is bugged or perhaps I pressed the wrong combination of shortcut keys and changed some setting.

Every object in my scene is rotating around the 3D coordinate systems origin and not the objects origin. That's why my camera and empties are rotating off the path even if I lock all the selected objects axis rotations.

Any object I select, the camera, the field, the particle emitters, the empties and any new objects I add to the scene have a dotted line connected to the origin of the scene. If I try Shift-Ctrl-Alt-C and set the origin to the objects mass or geometry, it makes no difference. The objects origin stays locked to the origin of the scene.

I may start another thread in the future and include my broken blender file.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.