1
$\begingroup$

In solid view, my object's smooth however in render mode it's not. What's the problem?

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Can you share the Blender file? $\endgroup$ – Mike Pan Feb 18 '18 at 18:51
  • $\begingroup$ Does this help? blender.stackexchange.com/questions/55417/… $\endgroup$ – Ray Mairlot Feb 18 '18 at 18:57
  • $\begingroup$ This shouldn't happen. Maybe try entering Edit mode, select all and use W > Shade Smooth to explicitly enable smooth shading (as I see there aren't any modifiers on the object). Increasing amount of geometry is kind of workable (though it works around not solving it completely) but not efficient way $\endgroup$ – Mr Zak Feb 18 '18 at 20:01
  • $\begingroup$ @MrZak increasing the face count until the faces are smaller than a single pixel is a bit resource intensive, I agree. $\endgroup$ – Haunt_House Feb 18 '18 at 20:03
1
$\begingroup$

Solved! Just increased value of view in render in subdivision surface modifier

$\endgroup$
  • 1
    $\begingroup$ That would make the faces smaller, but not really solve the issue. I tried to recreate it, but somehow I fail so far. $\endgroup$ – Haunt_House Feb 18 '18 at 20:01
  • $\begingroup$ it didn't help much that you didn't explain in question about using a subsurf modifier... you just talked about smooth... that is a different thing! You should expand your question adding images/details about your exact setup, and thus this answer would be more useful to others... $\endgroup$ – m.ardito Feb 18 '18 at 20:59
  • $\begingroup$ @Haunt_House I guess the OP used a subsurf high "view" level but low "render" level. But "shading" was solid, not smooth. "smoothing" in 3d viewport was perceived thanks to high (view) subsurf level... $\endgroup$ – m.ardito Feb 18 '18 at 21:01
  • $\begingroup$ @m.ardito Could be. Yet the specular lighting artifacts look not very high poly at all. And the outline is identical. I could be wrong. Depends on whether she has pressed the smooth button to the left of the screenshot ( : I couldn't get cycles to stay solid with that enabled so far. Hey Liana. Have you pressed that smooth shading button on the left side of the screenshot while the object is selected? $\endgroup$ – Haunt_House Feb 18 '18 at 21:31
1
$\begingroup$

Here is what I think you could have done: you didn't set the object as "smooth" shading with the toolbox button visible in your images, and you had a subsurf with a low "render" level, like 1 but high "view" level...

This makes the object appear "smooth" (thanks to the subsurf settings) in the 3d view but "solid" when rendered.

enter image description here

$\endgroup$
  • $\begingroup$ You can see in the screenshot the object has no modifiers on it. $\endgroup$ – Ray Mairlot Feb 19 '18 at 17:00
  • $\begingroup$ @RayMairlot Liana's answer is "Just increased value of view in render in subdivision surface modifier"... only Liana could explain exactly how that object was set... $\endgroup$ – m.ardito Feb 19 '18 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.