0
$\begingroup$

For some reason, when I add the Subdvision Surface modifier, I'm getting this. Does anyone know what might be causing this?

$\endgroup$

2 Answers 2

2
$\begingroup$

Subdivision surface only works well with quads, and from the looks of it your model isn't constructed in the most clean way. There are a few things you can try short of remodelling the mesh:

  1. Remove doubles
  2. Recalculate Normals
  3. Add a bevel modifier, which might be able to clean up the edges for you so you can apply a subsurface modifier.
  4. Add 2 edge loops around the perimeter of the object so that subdivision works better.

enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ I've done the model with vertices(Drawing around a reference image) and then filled the edges to create a single face on top and on bottom, after that I extruded the face. I believe this might be the problem, how would you model it, with a cube? (I'm only a student so I have the time to remodel it all). Thanks in advance. Edit: And it's a single model too, would you recomend separating it in different models? $\endgroup$
    – Aquawu
    Commented Feb 17, 2018 at 21:30
  • $\begingroup$ Bevel modifier or adding edge loops(Ctrl+R) is probably the easiest way to fix it. $\endgroup$
    – Mike Pan
    Commented Feb 17, 2018 at 23:25
  • $\begingroup$ Neither one worked, so I'm going to remodel it as a cube. I think my problem is that the top part only has one face $\endgroup$
    – Aquawu
    Commented Feb 17, 2018 at 23:35
  • $\begingroup$ The issue is the way the top face is connected to the sides. Polygons with more than 4 sides do not subdivide well. See this answer:blender.stackexchange.com/questions/3199/… $\endgroup$
    – user1853
    Commented Feb 17, 2018 at 23:42
1
$\begingroup$

My recomendation: Remodel it. Start from scratch and make sure that you are using squares to build it. Then, when the subdiv is applied it will look much cleaner and will be much easier to control. Alternatively, you can try sculpting with Dynotopo enabled (Dynamic topology). This will allow you to add exactly as much detail as you need, or even more detail than you need (which you can reduce later with a decimate modifier). Hope this helps.

$\endgroup$
1
  • $\begingroup$ Yeah man, that's what I'm going to do, I thought I could do it with vertices but I couldn't. Thanks $\endgroup$
    – Aquawu
    Commented Feb 17, 2018 at 23:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .