1
$\begingroup$

Could someone take a quick look at this node tree and tell me what i'm doing wrong? The colour ramps have no effect at all on the target....unless you swap the white and black around completely .......not just this node tree either . I'm getting this a lot. The only way I seem to be able to get stuff to change is by changing the mix shaders to other settings such as soft light and burn??!![enter image description here]1

$\endgroup$
  • 2
    $\begingroup$ Do you have the Node Wrangler addon enabled? It allows you to preview what's happening at each node, which can be a lifesaver when trying to get to the bottom of an issue like this. gregzaal.github.io/node-wrangler Ctrl-Shift-Click to preview a node. Unfortunately without seeing your image textures and what effect you're trying to get it's very hard to get a sense of what's going on. Uploading a Blend file might help. $\endgroup$ – risingfall Feb 16 '18 at 22:28
  • $\begingroup$ yes.... I have the Node Wrangler working and am even using the mute function to try to geet a handle on this. Probably a silly question but where/how do I upload a blend file please? $\endgroup$ – David Oulton Feb 16 '18 at 23:12
  • $\begingroup$ A file hosting service would be a good bet, like Dropbox, Google Drive, OneDrive, etc. Post a link to the file in your question. $\endgroup$ – risingfall Feb 17 '18 at 0:50
  • $\begingroup$ Blend files should be shared on blend-exchange.giantcowfilms.com as it’s specifically for that purpose and linked to BSE. As for the color ramps, are you sure they aren’t working at all or is it just responding to a very narrow range? - the Noise texture used in that way will only be producing values close around the range 0.45 - 0.55. You’ll get better range by splitting the channels using Separate RGB and use, say, just the R (otherwise you’re effectively averaging three random channel which will tend towards 0.5). Even so, you’ll need to expand the values to use full range. $\endgroup$ – Rich Sedman Feb 17 '18 at 9:41
  • $\begingroup$ with Node Wrangler enabled click on your Color Ramp while holding Ctrl+Shift pressed and do the same your noise texture, because probably the scale is just way to big or small so you dont really see anything of the texture. Also check your add nodes outputs. Perhaps they output pure white in some areas. You would normally use Mix nodes but probably it has a reason why its add I guess $\endgroup$ – HenrikD Feb 17 '18 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.