3
$\begingroup$

I was working on a project in 2.79 with avastar, when I was suddenly unable to see, select, or edit newly added objects in object mode. I can add objects just fine in edit mode, but not in object mode. the objects appear in my outliner, but they will not appear in the 3d viewer. This includes curves and every other type of object. None work.

I've tried:

  • disabling all add-ons, saving user settings then rebooting blender
  • restarting my PC
  • deleting everything out of the scene
  • opening a fresh startup scene, then opening the project file with "load UI" option UN-ticked

When I load the startup scene, everything works just fine. But my project file seems to be affected.

How do I fix this?

$\endgroup$
  • $\begingroup$ You might want to save your file under a separate name, strip the copy of all unnecessary stuff so it's small and then upload it. That makes it much easier to find the course of the trouble. By the way, what coordinates does your 3D Cursor have? $\endgroup$ – Haunt_House Feb 13 '18 at 11:08
3
$\begingroup$

You may need to look a little harder at the outliner objects.

enter image description here

If the little eyeball next to the hidden objects is off, then the object will be hidden in the viewport.

If this is the case then with your mouse cursor over your 3D viewport, Alt+H will turn this back on for these objects.

Also you may need to check if you are currently using the scene's active layer...

If your 'Lock camera and layers' button looks like the following, you will want to click it to toggle the lock.

enter image description here

Related to the last comment, you may need to hit ` (Backtick) to toggle all of your layers on.

Otherwise the only other thing that I can think of is viewport clipping.

enter image description here

If you are having trouble getting to this panel, with your mouse cursor over the 3D viewport hit the N key to toggle.

Then try increasing your clip distance.

You may also have to do the same for your camera for rendering, but that setting will be found in the properties panel >> Object Data >> Clipping

enter image description here

$\endgroup$
2
$\begingroup$

Just a hunch, but if they show up in your Outliner, that means you do add them. Select any of those objects with a left click in the outliner and then in the 3D View, open the View menu and choose View Selected. That should center your view on the object in question.

view selected

Could be that your 3D Cursor is far away. You can check it's coordinates in the properties. Or you can check the object's coordinates in the Transform panel.

3d cursor coords

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.