1
$\begingroup$

I'm not English speaker, so i don't know how to explain my problem correctly, but i'll try

Hello, my friends. I newbie in Blender and modeling in general, and i have problem with hair. I'm trying to make long hair of my character, but when i'm trying to use children with interpolated mode, i see that some children are going through the head and neck. Of course, i have an separate mesh for hair. Screenshot shows hot it looks like. hair problem

(number of children in preview equals 20)

The second screenshot shows particles. Yes, there is so many parents, but i need to make hairstyle looks exactly how i want. You can see that there is no parents intersecting with mesh (with the exception of a couple).

enter image description here

But when i activate children, i see bad picture.

I tried to find answer and did next steps: 1. Duplicate mesh with hair. 2. Deleted all particles from second mesh. 3. Removed second mesh from render. 4. Activated collision in second mesh. 5. Setted outer = 0.500, inner = 0.2, particle damping factor = 0.4;

If be honest i don't know last step and what does it all mean, 'cause i still learning and i have not even reached it yet.

Maybe problem comes from completely different side? I spent the whole day trying to figure out what's wrong, but still got nothing.

Blender's community is my last hope.

$\endgroup$
1
  • $\begingroup$ Ok, i learnt that problem's going from places where two directions of hair parents are intersecting. So i just divide mesh by two parts. It solved my problem, but i got some difficulties with hairstyle editing and, i gues, adding hair dynamics. $\endgroup$
    – Mateil
    Feb 13, 2018 at 20:03

1 Answer 1

0
$\begingroup$

This question is still relevant in Blender 3.5 and with the new hair curves. I have just come across this problem. It is time to write down the solution noted in the comment above.

Problem: You create a hair cap and add some hair curves. They should work as guides for the interpolated hair children. Everything looks fine:

hair guides

Then you use the Interpolate Hair Curves asset that comes with Blender 3.5. It adds a Geometry Nodes modifier and your model will look as the one shown below.

The interpolated hair goes straight through the hair cap mesh and will intersect with the head. This is not what we want. The hair children should follow their guides along the head above the surface.

hair children intersect the mesh

Solution:

  1. separate the hair guides into 2 or more curve objects so they don't go into the opposite direction. For example: left, right, and back. There is still a few intersecting hair strands. But this is because of the displacement by the Frizz Hair Curves and Hair Curves Noise modifiers.

separated hair guides

  1. define exactly where the roots of the guides and children are and should be (hair density map). The modifier Interpolate Hair Curves has the Density Mask option where you can specify a vertex group or use the Mask Texture option where you can specify an image texture that serves as a mask (white/1=hair, black/0=no hair).

vertex group for hair density

In the old particle system you do the same under Vertex Groups > Density. Or add a texture under Textures. On the Texture Properties tab, you specify that the hair density should be influenced with the Influence > Density setting.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .