3
$\begingroup$

I have plane with glossy material and point light.

enter image description here

You can see the white dot in the plane as point light.

enter image description here

How to retain glossy plane but so that point light is not seen on the plane ?

EDIT: I have tried to modify point lamp material but lamp is still on glassy plane. enter image description here

$\endgroup$
  • $\begingroup$ I changed material of point light but the light is still seen on glossy plane. $\endgroup$ – Wildfire Feb 10 '18 at 13:04
  • $\begingroup$ As I look into the question now I don't understand what are you trying to do. If you remove light source visibility from the plane its "glossiness" won't be visible as it's visible because light source is visible in the plane. If you don't remove it then there's no reason to set up anything - light source itself won't be visible to camera as it's a lamp. If you want light source to only lighten up the object and glossy plane to reflect only the background uncheck Glossy in light source settings $\endgroup$ – Mr Zak Feb 10 '18 at 14:05
2
$\begingroup$

If I understand correctly this is the result you are after:

final

To achieve this you will need to mix Emission with Transparent (pure white colour- #FFFFFF) shaders in Lamp material by Light Path > Glossy Depth as below:

node_setup

Note: If you change Glossy Roughness (should be 0) even a bit, light will still be visible.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.