1
$\begingroup$

I did a few tests now and so far nothing works except if I change the material entirely, which I do not want to do.

Basically, I have finished my project and need to render it, and I want to use a renderfarm (SheepIt in this case) to save several days/hours. So I need to Pack everything to into the .blend file.

I placed all the textures in same root folder as the .blend file.

The .blend file is in this location:

  • D:\Program\Blender Foundation\Project Folder\Landscape

All my textures are in this folder:

  • D:\Program\Blender Foundation\Project Folder\Landscape\textures

Different objects textures have sub-folders:

  • D:\Program\Blender Foundation\Project Folder\Landscape\textures\Shaft
  • D:\Program\Blender Foundation\Project Folder\Landscape\textures\Shield
  • D:\Program\Blender Foundation\Project Folder\Landscape\textures\Sword
  • D:\Program\Blender Foundation\Project Folder\Landscape\textures\ToonLinkBody
  • D:\Program\Blender Foundation\Project Folder\Landscape\textures\Navi

On SheepIt.com: When I upload without pressing this: File > External Data > Pack All into .blend I get this warning: Cannot find file. and it spams all the textures missing.

When I upload, having this pressed: File > External Data > Pack All into .blend I get no warnings. But the rendered picture at the end looks like the shading is totally weird, as if the material drastically changed itself.

But! I still get the results below when I render on my own computer:

Picture 1: Without File > External Data > Pack All into .blend

Picture 2: With File > External Data > Pack All into .blend

What am I doing wrong. Why does packing change the glossy/light on those specific materials? I thought packing a blend file, everything would still look the same. To get a decent result with packing, I had to tweak my materials alot, and I am still not happy with them comparing to the "original" if you know what I mean.

Is it only these 3 objects in the entire scene that gets affected by packing into .blend

Toon Shader Diffuse Toon Shader Glossy Mix Shader.

Diffuse Map (color) Normal Map

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Sounds like a bug, that shouldn't happen. If you can recreate it and provide a file showing the issue you should report it. $\endgroup$ – Duarte Farrajota Ramos Feb 7 '18 at 1:20
  • $\begingroup$ I uploaded the .blend file on a simple upload page: pasteall.org/blend/index.php?id=48879 1. Opened new scene. 2. Imported object (One of those wierd after packing). 3. Changed Lamp into Sun. 4. Rotated Sun for similar angle as in my project. 5. Rotated object for similar angle as my project. 6. Added sky texture under World. Surface: Background Color: Sky Texture 7. Checked Ambient Occlusion, changed factor to 0.10. 8. Changed Strenght of sky texture to 2.5 9. Pressed File>External Data>Pack All into .blend 10. Uploaded .blend file to this forum $\endgroup$ – Socka Feb 7 '18 at 9:35
  • $\begingroup$ I edited my objects textures abit. Still same parts of the textures! Almost identical scene settings in a .blend file At point 8, the scene lights and material almost look identical to my projects At point 9, same thing happens, everything gets dark in render and in preview window render. Something with the material Nodes aint co-operating with the packing function, which makes no sense to me, as I mentioned above. Packing files into the .blend should not affect the material itself. Changing the material settings should change the outcome, nothing else. Don't you agree? $\endgroup$ – Socka Feb 7 '18 at 9:39
  • 2
    $\begingroup$ You should use blend-exchange.giantcowfilms.com instead because pasteall deletes the blend file after a period of time. $\endgroup$ – Retrax Feb 12 '18 at 16:49
0
$\begingroup$

I have had similar issues with packing files into blend. I have found that my lighting is corrupted while packed, but if I unpack the blend after I've moved it to wherever it needs to be the lighting goes back to normal. So pack -> move -> unpack -> save -> render

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.