4
$\begingroup$

I'm using two graphic cards in my system. I have recently replaced an old AMD gpu with a GT 710. Now blender is using the GT 710 instead of the much more powerful GTX 760. Blender now is painfullly slow and already stutters at 100k verts.

enter image description here

Anybody knows how I can choose what GPU Blender should run on?

Blender GPU settings as requested:

enter image description here

EDIT

All my programs start in Monitor 1. Blender starts in Monitor 4. Don't know why, but they are all connected to the GTC 760

enter image description here

$\endgroup$
3
+50
$\begingroup$

What you want to do is control which GPU the OpenGL context is created on. Luckily the latest Nvidia Driver has a way to do that.

Open the Nvidia Control Panel, and navigate to this setting: enter image description here

|improve this answer|||||
$\endgroup$
2
$\begingroup$

If you have your primary monitor attached to the GT 710 then Blender (and any program creating an OpenGL context) will be using that instead. Make sure that the GTX 760 is set to drive your primary monitor.

If you have only one monitor attached to your machine, make sure it is attached to the GTX 760.

If you have multiple monitors attached to your machine, make sure at least one is attached to the GTX 760, and make sure that this display is set to be your primary display.

To change the primary display right-click on the desktop and select Display Settings display settings in desktop context menu

Note though that when you set the GTX 760 as your primary display adapter and you use it as your Cycles compute device you will run into stuttering display for entire Windows while rendering.

|improve this answer|||||
$\endgroup$
0
$\begingroup$

I would try this http://www.nvidia.com/object/performance_group.html

I've never used it but it looks like it might be what you're looking for.

|improve this answer|||||
$\endgroup$
0
$\begingroup$

While there are many different factors that can be contributing to this problem, I highly recommend changing your default graphics card in the Nvidia control panel. If you right click on the desktop, you can access it there. Go to "Manage 3D Settings" on the left side, choose the "Program Settings" tab in that window, and select Blender (or other programs you're having issues with, too" and change the settings in the drop-down box below it to "High Performance Nvidia Processor."

|improve this answer|||||
$\endgroup$
0
$\begingroup$

Try to switch place on the two GPU, the problem is most likely that the GT 710 do have a lower address value and blender find it before the 760. If that isn't enough it might help reinstalling them and in the worst case you can try to uninstall the 710 and hope that blender prefer a GPU with Nvidia/AMD drivers.

If you are really unlucky it can be that the serial number or address name is screwing with it and can't be solved without editing the code.

I'm more or less 100% on that it is a problem caused by the address name because the GT 710 is GPU 0 in task manager and is more likely to be used than GPU 1.

I have actually never had this problem but the solution is to make the better GPU the one with a lower number.

(You might be stuck with how it is depending on what motherboard you have and how windows react on changes, it is possible that windows will keep calling the 710, GPU 0 because it is registered as it once)

|improve this answer|||||
$\endgroup$
  • $\begingroup$ I have a PCIEx16 slot and a PCIEx4 slot. The 710 uses one lane, the GTX760 uses 8 lanes. It would be daft to switch them. Also, it is only 2 programs that access the 710 instead of the GTX760. All other programs, including games, run on the GTX760 $\endgroup$ – AzulShiva Feb 17 '18 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.